diff mbox series

[bug#43182,2/3] gnu: g-golf: Update to git hash 84e894e.

Message ID 20200904144053.1981499-2-mike.rosset@gmail.com
State Accepted
Headers show
Series [bug#43182,1/3] gnu: emacsy-minimal: Update to v0.4.1-31-g415d96f. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Mike Rosset Sept. 4, 2020, 2:40 p.m. UTC
* gnu/packages/guile-xyz.scm (g-golf): Update to git hash 84e894eb.

This also fixes the version to the correct one which is 0.1.0.  Technically
g-golf does not actually have a release yet.  The author of g-golf confirmed
versions will start at 0.1.0 as autotools currently has that version.

Note: this could break guix upgrade since version 0.1.0 is lower then 1.  But
it's better to fix this now then later.  Since they are few if any g-golf
users.
---
 gnu/packages/guile-xyz.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b43c72dcf3..5164dc91c5 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1729,19 +1729,19 @@  capabilities.")
     (license license:gpl3+)))
 
 (define-public g-golf
-  (let ((commit "5d2903afb4b6b65c22f587835d8fdff91916e5ee"))
+  (let ((commit   "84e894eb7945c3bcdf7f8d5135c1be3efa524c92")
+        (revision "822")
+        (hash     (base32 "1pkcij65zy2lkip5yrfzj85nq17pp9mrf0d4sk6hpjqr4kd0bxd5")))
     (package
       (name "g-golf")
-      (version (git-version "1" "804" commit))
+      (version (git-version "0.1.0" revision commit))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
                       (url "https://git.savannah.gnu.org/git/g-golf.git")
                       (commit commit)))
                 (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1xkb6a5d3i9s8lpb5cf06bd64p5srqnnhn5l0b2f5csbvyz8hmmh"))))
+                (sha256 hash)))
       (build-system gnu-build-system)
       (native-inputs
        `(("autoconf" ,autoconf)