diff mbox series

[bug#43098] gnu: reuse: Update to 0.11.1.

Message ID 20200829025545.10796-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#43098] gnu: reuse: Update to 0.11.1. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder Aug. 29, 2020, 2:55 a.m. UTC
* gnu/packages/license.scm (reuse): Update to 0.11.1.
[native-inputs]: added python-setuptools-scm.
---
 gnu/packages/license.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Comments

Leo Famulari Aug. 29, 2020, 6:53 p.m. UTC | #1
On Sat, Aug 29, 2020 at 04:55:45AM +0200, Michael Rohleder wrote:
> * gnu/packages/license.scm (reuse): Update to 0.11.1.
> [native-inputs]: added python-setuptools-scm.

Thanks! Pushed as a046c03e139af4dcbe4cab3841fc7377f1152295
diff mbox series

Patch

diff --git a/gnu/packages/license.scm b/gnu/packages/license.scm
index 36bcb75f8d..975608c79b 100644
--- a/gnu/packages/license.scm
+++ b/gnu/packages/license.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -168,16 +169,17 @@  belonging to various licenses.")
 (define-public reuse
   (package
     (name "reuse")
-    (version "0.7.0")
+    (version "0.11.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "reuse" version))
        (sha256
-        (base32 "16wn28xxjcm5qlb7bs6jmdkfrkr5v97s59nmi9cn85qcg4gmj7lk"))))
+        (base32 "09qjb4f49vr0a7zrszab8g719ilg2p6b942mr0bgyvplrjikkid5"))))
     (build-system python-build-system)
     (native-inputs
-     `(("python-pytest" ,python-pytest)))
+     `(("python-pytest" ,python-pytest)
+       ("python-setuptools-scm" ,python-setuptools-scm)))
     (inputs
      `(("python-binaryornot" ,python-binaryornot)
        ("python-boolean.py" ,python-boolean.py)