diff mbox series

[bug#43074,2/2] gnu: radicale: Update to 3.0.4.

Message ID 20200827210024.50409-1-monego@posteo.net
State Accepted
Headers show
Series [bug#43074,1/2] gnu: Add xandikos. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Vinicius Monego Aug. 27, 2020, 9 p.m. UTC
* gnu/packages/dav.scm (radicale): Update to 3.0.4.
---
 gnu/packages/dav.scm | 39 +++++++++++++++++++++++++++------------
 1 file changed, 27 insertions(+), 12 deletions(-)

Comments

Leo Famulari Aug. 27, 2020, 9:19 p.m. UTC | #1
On Thu, Aug 27, 2020 at 06:00:24PM -0300, Vinicius Monego wrote:
> * gnu/packages/dav.scm (radicale): Update to 3.0.4.

Thanks! I completed the commit message for this patch and pushed 
as 828658f8fe6721215dbe5fd49702ae63121a8573
diff mbox series

Patch

diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index ab50c86f14..f56a3a837b 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -24,30 +24,46 @@ 
   #:use-module (guix download)
   #:use-module (guix licenses)
   #:use-module (guix packages)
+  #:use-module (guix git-download)
   #:use-module (gnu packages)
   #:use-module (gnu packages check)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-check)
+  #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages sphinx)
+  #:use-module (gnu packages time)
   #:use-module (gnu packages xml))
 
 (define-public radicale
   (package
     (name "radicale")
-    (version "1.1.6")
-    (source (origin
-             (method url-fetch)
-             (uri (pypi-uri "Radicale" version))
-             (sha256
-              (base32
-               "0ay90nj6fmr2aq8imi0mbjl4m2rzq7a83ikj8qs9gxsylj71j1y0"))))
+    (version "3.0.4")
+    (source
+     (origin
+       ;; There are no tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Kozea/Radicale")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0hj9mmhrj32mzhxlnjcfijb7768cyjsn603nalp54clgb2gkmvw8"))))
     (build-system python-build-system)
-    (arguments
-     '(#:tests? #f)) ; The tests are not distributed in the PyPi release.
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-flake8" ,python-pytest-flake8)
+       ("python-pytest-isort" ,python-pytest-isort)
+       ("python-pytest-runner" ,python-pytest-runner)
+       ("python-waitress" ,python-waitress)))
     (propagated-inputs
-      ;; TODO: Add python-pam
-     `(("python-requests" ,python-requests)))
+     `(("python-dateutil" ,python-dateutil)
+       ("python-defusedxml" ,python-defusedxml)
+       ("python-passlib" ,python-passlib)
+       ("python-vobject" ,python-vobject)))
+    (home-page "https://radicale.org/")
     (synopsis "Basic CalDAV and CardDAV server")
     (description "Radicale is a CalDAV and CardDAV server for UNIX-like
 platforms.  Calendars and address books are available for both local and remote
@@ -57,7 +73,6 @@  and edited by calendar and contact clients on mobile phones or computers.
 Radicale intentionally does not fully comply with the CalDAV and CardDAV RFCs.
 Instead, it supports the CalDAV and CardDAV implementations of popular
 clients.")
-    (home-page "https://radicale.org/")
     (license gpl3+)))
 
 (define-public xandikos