diff mbox series

[bug#43059,6/7] gnu: Add python-trytond-purchase-request.

Message ID 20200826135154.33620-5-monego@posteo.net
State Accepted
Headers show
Series [bug#43059,1/7] gnu: Add python-trytond-analytic-account. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Vinicius Monego Aug. 26, 2020, 1:51 p.m. UTC
* gnu/packages/tryton.scm (python-trytond-purchase-request): New variable.
---
 gnu/packages/tryton.scm | 52 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 461e1faf36..79a38d2e01 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -791,6 +791,58 @@  average price of the posted invoice lines that are linked to it.")
      "This package provides a Tryton module that defines the Purchase model.")
     (license license:gpl3+)))
 
+(define-public python-trytond-purchase-request
+  (package
+    (name "python-trytond-purchase-request")
+    (version "5.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_purchase_request" version))
+       (sha256
+        (base32 "15r1x3jzr83rna1vfpans277785dpmgjr7989icav602nkyhhx0x"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (let ((runtest
+                  (string-append
+                   (assoc-ref %build-inputs "python-trytond")
+                   "/lib/python"
+                   ,(version-major+minor (package-version python))
+                   "/site-packages/trytond/tests/run-tests.py")))
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (add-installed-pythonpath inputs outputs)
+               ;; Doctest 'scenario_purchase_request.rst' fails.
+               (invoke "python" runtest "-m" "purchase_request" "--no-doctest")))))))
+    (native-inputs
+     `(("python" ,python-minimal-wrapper)
+       ("python-dateutil" ,python-dateutil)
+       ("python-genshi" ,python-genshi)
+       ("python-lxml" ,python-lxml)
+       ("python-magic" ,python-magic)
+       ("python-passlib" ,python-passlib)
+       ("python-polib" ,python-polib)
+       ("python-proteus" ,python-proteus)
+       ("python-relatorio" ,python-relatorio)
+       ("python-sql" ,python-sql)
+       ("python-werkzeug" ,python-werkzeug)
+       ("python-wrapt" ,python-wrapt)))
+    (propagated-inputs
+     `(("python-trytond" ,python-trytond)
+       ("python-trytond-product"
+        ,python-trytond-product)
+       ("python-trytond-purchase"
+        ,python-trytond-purchase)))
+    (home-page "https://www.tryton.org/")
+    (synopsis "Tryton module for purchase requests")
+    (description
+     "This package provides a Tryton module that introduces the concept of
+Purchase Requests which are central points to collect purchase requests
+generated by other process from Tryton.")
+    (license license:gpl3+)))
+
 (define-public python-proteus
   (package
     (name "python-proteus")