diff mbox series

[bug#43045,4/7] gnu: Add python-requests-toolbelt-0.9.1.

Message ID 20200825173735.16156-4-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#43045,1/7] gnu: Add python-pure-protobuf. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Leo Prikler Aug. 25, 2020, 5:37 p.m. UTC
* gnu/packages/python-web.scm (python-requests-toolbelt-0.9.1): New variable.
---
 gnu/packages/python-web.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1b97d1401d..f7a623ceba 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2003,6 +2003,20 @@  with python-requests.")
 (define-public python2-requests-toolbelt
   (package-with-python2 python-requests-toolbelt))
 
+(define-public python-requests-toolbelt-0.9.1
+  (package
+    (inherit python-requests-toolbelt)
+    (version "0.9.1")
+    (source (origin
+             (method url-fetch)
+             (uri (pypi-uri "requests-toolbelt" version))
+             (sha256
+              (base32
+               "1h3gm88dcjbd7gm229a7x5qkkhnsqsjz0m0l2xyavm2ab3a8k04n"))))
+    (arguments
+     `(;; FIXME: Some tests require network access.
+       #:tests? #f))))
+
 (define-public python-oauthlib
   (package
     (name "python-oauthlib")