diff mbox series

[bug#42980] gnu: jekyll: Loosen the requirement for kramdown.

Message ID 20200822010842.16967-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#42980] gnu: jekyll: Loosen the requirement for kramdown. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder Aug. 22, 2020, 1:08 a.m. UTC
* gnu/packages/ruby.scm (jekyll): Loosen the requirement for kramdown.
---
commit 2b5b7809b6e91f7e35cc5f082af815c0a4725d58 (update ruby-kramdown)
broke building ruby-jekyll-paginate-v2.

 gnu/packages/ruby.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Nicolas Goaziou Aug. 22, 2020, 11:24 a.m. UTC | #1
Hello,

Michael Rohleder <mike@rohleder.de> writes:

> * gnu/packages/ruby.scm (jekyll): Loosen the requirement for kramdown.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 010028082a..3ff93d2252 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2019 Brett Gilio <brettg@posteo.de>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -10986,7 +10987,8 @@  Pathname.")
          (add-before 'build 'fix-i18n
            (lambda _
              (substitute* ".gemspec"
-               (("~> 0.7") ">= 0.7"))
+               (("~> 0.7") ">= 0.7")
+               (("~> 1.14") ">= 1.14"))
              #t)))))
     (propagated-inputs
      `(("ruby-addressable" ,ruby-addressable)