diff mbox series

[bug#42958,core-updates,02/29] gnu: yelp-tools: Update package definition.

Message ID 20200820151050.9529-2-dannym@scratchpost.org
State Accepted
Headers show
Series Big changes from wip-desktop. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Danny Milosavljevic Aug. 20, 2020, 3:10 p.m. UTC
From: Raghav Gururajan <raghavgururajan@disroot.org>

* gnu/packages/gnome.scm (yelp-tools): Update package definition.
[propagated-inputs]: Move itstool, libxml2 and libxslt to ...
[native-inputs]: ... here.
[synopsis]: Modify.
[description]: Modify.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
---
 gnu/packages/gnome.scm | 30 +++++++++++++-----------------
 1 file changed, 13 insertions(+), 17 deletions(-)

Comments

Ludovic Courtès Aug. 30, 2020, 8:54 p.m. UTC | #1
Hi!

Danny Milosavljevic <dannym@scratchpost.org> skribis:

> From: Raghav Gururajan <raghavgururajan@disroot.org>
>
> * gnu/packages/gnome.scm (yelp-tools): Update package definition.
> [propagated-inputs]: Move itstool, libxml2 and libxslt to ...
> [native-inputs]: ... here.
> [synopsis]: Modify.
> [description]: Modify.
>
> Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>

I think “Update package definition” is not descriptive: it should be
either “Update to 3.36” (for a version update), or “Move build-time tool
to 'native-inputs'”, or “Tweak synopsis and description”.  But then,
these are different kinds of changes (I know, you’ll hate me for
suggesting another rebase…).  I find it important to clearly communicate
among us what a change does.

WDYT?

Also, while it’s maybe more convenient for Outreachy, I think many of
these changes could have gone one by one on ‘master’ over time, like
Raghav used to do.  That avoids the pressure associated with a 29-patch
review.

> +    (synopsis "Tools for Yelp")
> +    (description "Yelp-Tools contains small programs that help you create, edit,
> +manage, and publish your Mallard or DocBook documentation.")
>      (home-page "https://wiki.gnome.org/Apps/Yelp/Tools")
> -    (synopsis "Yelp documentation tools")
> -    (description
> -     "Yelp-tools is a collection of scripts and build utilities to help create,
> -manage, and publish documentation for Yelp and the web.  Most of the heavy
> -lifting is done by packages like yelp-xsl and itstool.  This package just
> -wraps things up in a developer-friendly way.")

This particular change is questionable IMO.

Anyhow, thanks to the two of you for all the work!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5dda82d295..881cfa493d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5775,31 +5775,27 @@  freedesktop.org help system specification.")
   (package
     (name "yelp-tools")
     (version "3.32.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/" name "/"
-                                  (version-major+minor version) "/"
-                                  name "-" version ".tar.xz"))
-              (sha256
-               (base32
-                "1yg8f5g5wadhmy4yfd9yjhvd8vll4gq4l86ibp0b42qbxnsmcf0q"))))
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "mirror://gnome/sources/" name "/"
+                       (version-major+minor version) "/"
+                       name "-" version ".tar.xz"))
+       (sha256
+        (base32 "1yg8f5g5wadhmy4yfd9yjhvd8vll4gq4l86ibp0b42qbxnsmcf0q"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
-    (propagated-inputs
-     ;; Needed by `yelp-build', `yelp-check' or 'yelp.m4'.
      `(("itstool" ,itstool)
+       ("pkg-config" ,pkg-config)
        ("xmllint" ,libxml2)
        ("xsltproc" ,libxslt)))
     (inputs
      `(("yelp-xsl" ,yelp-xsl)))
+    (synopsis "Tools for Yelp")
+    (description "Yelp-Tools contains small programs that help you create, edit,
+manage, and publish your Mallard or DocBook documentation.")
     (home-page "https://wiki.gnome.org/Apps/Yelp/Tools")
-    (synopsis "Yelp documentation tools")
-    (description
-     "Yelp-tools is a collection of scripts and build utilities to help create,
-manage, and publish documentation for Yelp and the web.  Most of the heavy
-lifting is done by packages like yelp-xsl and itstool.  This package just
-wraps things up in a developer-friendly way.")
     (license license:gpl2+)))
 
 (define-public libgee