diff mbox series

[bug#42939] gnu: drawpile: Build with libmicrohttpd 0.9.71.

Message ID 20200819214931.15292-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#42939] gnu: drawpile: Build with libmicrohttpd 0.9.71. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder Aug. 19, 2020, 9:49 p.m. UTC
* gnu/packages/graphics.scm (drawpile)[arguments]: Add patch phase.
---
 gnu/packages/graphics.scm | 16 +++++++++++++++-
 1 file changed, 15 insertions(+), 1 deletion(-)

Comments

Mathieu Othacehe Aug. 24, 2020, 7:19 a.m. UTC | #1
Hello Michael,

> +         ;; libmicrohttpd>=0.9.71 changed some results from int to MHD_Result.
> +         (add-after 'unpack 'patch
> +           (lambda _
> +             (substitute* "src/thinsrv/webadmin/qmhttp.cpp"
> +               (("^int assign_to_hash") "MHD_Result assign_to_hash")
> +               (("^int access_policy") "MHD_Result access_policy")
> +               (("^int iterate_post") "MHD_Result iterate_post")
> +               (("^int request_handler") "MHD_Result request_handler")
> +               (("int ret;") "MHD_Result ret;")
> +               (("ret = MHD_queue_basic_auth_fail_response")
> +                "ret = (MHD_Result) MHD_queue_basic_auth_fail_response"))
> +             #t)))))

I believe that this is fixed upstream by:
https://github.com/drawpile/Drawpile/commit/ed1a75deb113da2d1df91a28f557509c4897130e.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index c7fefbd57d..a5d6a8cad8 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1450,7 +1450,21 @@  Automated palette selection is supported.")
                 "08w8vad8pw4a8kkshys1kd2kjvzpj62klxxxp904rx0qazw5hl80"))))
     (build-system qt-build-system)
     (arguments
-     '(#:configure-flags (list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")))
+     '(#:configure-flags (list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")
+       #:phases
+       (modify-phases %standard-phases
+         ;; libmicrohttpd>=0.9.71 changed some results from int to MHD_Result.
+         (add-after 'unpack 'patch
+           (lambda _
+             (substitute* "src/thinsrv/webadmin/qmhttp.cpp"
+               (("^int assign_to_hash") "MHD_Result assign_to_hash")
+               (("^int access_policy") "MHD_Result access_policy")
+               (("^int iterate_post") "MHD_Result iterate_post")
+               (("^int request_handler") "MHD_Result request_handler")
+               (("int ret;") "MHD_Result ret;")
+               (("ret = MHD_queue_basic_auth_fail_response")
+                "ret = (MHD_Result) MHD_queue_basic_auth_fail_response"))
+             #t)))))
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)))