diff mbox series

[bug#42935] gnu: Add nicotine.

Message ID 20200819170318.20989-1-mjbecze@riseup.net
State Accepted
Headers show
Series [bug#42935] gnu: Add nicotine. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Martin Becze Aug. 19, 2020, 5:03 p.m. UTC
* gnu/packages/nicotine.scm (nicotine): New variable.
---
 gnu/packages/nicotine.scm | 67 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 67 insertions(+)
 create mode 100644 gnu/packages/nicotine.scm

Comments

Leo Famulari Aug. 22, 2020, 4:52 p.m. UTC | #1
On Wed, Aug 19, 2020 at 12:03:18PM -0500, Martin Becze wrote:
> * gnu/packages/nicotine.scm (nicotine): New variable.

Thank you! Awesome! Back to the future :)

I pushed with the following changes:

I also registered the new file in gnu/local.mk. Otherwise, it won't be
included in distribution tarballs.

> +(define-public nicotine
> +  (package
> +    (name "nicotine")

I changed it to be named "nicotine+". The plus sign is okay for Guix and
more accurate.

> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/Nicotine-Plus/nicotine-plus")
> +                    (commit version)))
> +              (sha256 (base32 "07xagm6kwy8b6gcdv5vx78yqfllkz1gvlakkf0hi2c9ivncq457g"))))

I added a file-name field so that the source code checkout would have a
descriptive name, and to satisfy `guix lint`.

> +         (add-after 'install 'wrap-assword

I renamed this phase to 'wrap-program'.
Martin Becze Aug. 22, 2020, 7:57 p.m. UTC | #2
Ahhh! thanks! I was wondering about that lint error.

On 8/22/20 11:52 AM, Leo Famulari wrote:
> I added a file-name field so that the source code checkout would have a
> descriptive name, and to satisfy `guix lint`.
Martin Becze Aug. 22, 2020, 7:57 p.m. UTC | #3
Ahhh! thanks! I was wondering about that lint error.

On 8/22/20 11:52 AM, Leo Famulari wrote:
> I added a file-name field so that the source code checkout would have a
> descriptive name, and to satisfy `guix lint`.
diff mbox series

Patch

diff --git a/gnu/packages/nicotine.scm b/gnu/packages/nicotine.scm
new file mode 100644
index 0000000000..1807dcee14
--- /dev/null
+++ b/gnu/packages/nicotine.scm
@@ -0,0 +1,67 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages nicotine)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system python)
+  #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages check)
+  #:use-module (gnu packages music))
+
+(define-public nicotine
+  (package
+    (name "nicotine")
+    (version "2.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Nicotine-Plus/nicotine-plus")
+                    (commit version)))
+              (sha256 (base32 "07xagm6kwy8b6gcdv5vx78yqfllkz1gvlakkf0hi2c9ivncq457g"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-assword
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((prog (string-append
+                          (assoc-ref outputs "out")
+                          "/bin/nicotine"))
+                   (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+               (wrap-program prog
+                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))
+               #t))))))
+    (inputs
+     `(("python-pygobject" ,python-pygobject)
+       ("python-mutagen" ,python-mutagen)
+       ("python-dbus" ,python-dbus)
+       ("gtk+" ,gtk+)))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page "https://nicotine-plus.github.io/nicotine-plus/")
+    (synopsis "Graphical client for Soulseek")
+    (description
+     "Nicotine+ is a graphical client for the Soulseek peer-to-peer
+file sharing network.  It is an attempt to keep Nicotine working with
+the latest libraries, kill bugs, keep current with the Soulseek protocol,
+and add some new features that users want and/or need.")
+    (license license:gpl3+)))