diff mbox series

[bug#42925,2/2] gnu: piper: Update to 0.5.1. Disable broken tests.

Message ID 20200819085656.21598-2-mail@brendan.scot
State Accepted
Headers show
Series [bug#42926,1/2] gnu: libratbag: Update to 0.14. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Brendan Tildesley Aug. 19, 2020, 8:56 a.m. UTC
* gnu/packages/gnome.scm (piper): Update to 0.5.1. Disable tests.
---
 gnu/packages/gnome.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Leo Famulari Aug. 22, 2020, 6:06 p.m. UTC | #1
On Wed, Aug 19, 2020 at 06:56:56PM +1000, Brendan Tildesley wrote:
> * gnu/packages/gnome.scm (piper): Update to 0.5.1. Disable tests.

Thanks! Pushed as d8e83969a9f87a2dffc3659cb1805b30ac7f92f1
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6a90e3c9eb..f0e8307501 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10996,7 +10996,7 @@  your operating-system definition:
 (define-public piper
   (package
     (name "piper")
-    (version "0.5")
+    (version "0.5.1")
     (source
      (origin
        (method git-fetch)
@@ -11004,7 +11004,7 @@  your operating-system definition:
              (url "https://github.com/libratbag/piper")
              (commit version)))
        (sha256
-        (base32 "00vrcsbsv2477l1ncpyzc61lhxgac84dsgr3sjs8qxw3nh1gaasv"))
+        (base32 "1nfjnsiwg2rs6gkjsxzhr2708i6di149dgwq3cf6l12rxqpb8arj"))
        (file-name (git-file-name name version))))
     (build-system meson-build-system)
     (native-inputs
@@ -11028,6 +11028,7 @@  your operating-system definition:
        #:modules (((guix build python-build-system) #:prefix python:)
                   (guix build meson-build-system)
                   (guix build utils))
+       #:tests? #f ;; The flake8 test fails trying to validate piper.in as code.
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'dont-update-gtk-icon-cache