diff mbox series

[bug#42923,1/5] gnu: Add meson/latest.

Message ID 20200818235856.31225-1-mail@brendan.scot
State Accepted
Headers show
Series [bug#42923,1/5] gnu: Add meson/latest. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brendan Tildesley Aug. 18, 2020, 11:58 p.m. UTC
* gnu/packages/build-tools.scm (meson/latest): New variable.
---
 gnu/packages/build-tools.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

ashish.is--- via Guix-patches" via Aug. 21, 2020, 8:45 p.m. UTC | #1
Thanks for your work on this!

I believe that you can make your latest version of meson a "hidden"
package.  You could name it something like "meson-latest", that way only
the newer version of sway would use it.  And it wouldn't require a
rebuild of the world.  Perhaps the same is true for wayland.

You can look for an example in the gcc.scm file.  They have gcc-4.7 as a
hidden package.  Users cannot install that package, instead they install
gcc-toolchain.

Thanks,

Joshua

--
Joshua Branson
Sent from Emacs and Gnus
diff mbox series

Patch

diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 7213c1bd0b..a464009761 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -222,6 +223,23 @@  resembles Python.")
     ;; People should probably install "meson", not "meson-for-build".
     (properties `((hidden? . #t)))))
 
+(define-public meson/latest
+  ;; The rpath patch is no longer needed since this issue was resolved:
+  ;; https://github.com/mesonbuild/meson/issues/2567
+  (package
+    (inherit meson)
+    (name "meson")
+    (version "0.55.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/mesonbuild/meson/"
+                                  "releases/download/" version  "/meson-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1070kjiirxxdfppmrhi3wsc6rykay1zlciqrzayjhjg0hkw42mrv"))))
+    (properties `((hidden? . #t)))))
+
 (define-public premake4
   (package
     (name "premake")