diff mbox series

[bug#42880] gnu: Add libde265.

Message ID 20200816015629.10838-1-monego@posteo.net
State Accepted
Headers show
Series [bug#42880] gnu: Add libde265. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego Aug. 16, 2020, 1:56 a.m. UTC
* gnu/packages/video.scm (libde265): New variable.
---
 gnu/packages/video.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Mathieu Othacehe Aug. 16, 2020, 7:48 a.m. UTC | #1
> +     "libde265 is an open source implementation of the h.265 video codec.  It is
> +written from scratch and has a plain C API to enable a simple integration into
> +other software.")

I removed "open source" from the description and pushed.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 5ea1067b35..dea0c81baa 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -318,6 +318,30 @@  television and DVD.  It is also known as AC-3.")
 shared library and encoder and decoder command-line executables.")
     (license license:bsd-2)))
 
+(define-public libde265
+  (package
+    (name "libde265")
+    (version "1.0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/strukturag/libde265")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qisj8ryzbknam3hk81rq70fsd9mcpxm898bqygvbsmbwyvmz3pg"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f)) ;there are no tests
+    (home-page "https://www.libde265.org/")
+    (synopsis "Open h.265 video codec implementation")
+    (description
+     "libde265 is an open source implementation of the h.265 video codec.  It is
+written from scratch and has a plain C API to enable a simple integration into
+other software.")
+    (license license:lgpl3+)))
+
 (define-public libmpeg2
   (package
     (name "libmpeg2")