diff mbox series

[bug#42879] gnu: Add python-sgp4.

Message ID 20200816014943.8866-1-monego@posteo.net
State Accepted
Headers show
Series [bug#42879] gnu: Add python-sgp4. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego Aug. 16, 2020, 1:49 a.m. UTC
* gnu/packages/python-science.scm (python-sgp4): New variable.
---
 gnu/packages/python-science.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Mathieu Othacehe Aug. 16, 2020, 7:47 a.m. UTC | #1
> * gnu/packages/python-science.scm (python-sgp4): New variable.

Pushed, thanks!

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 88843c1fb2..2d03e9a1ad 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -265,6 +265,26 @@  logic, also known as grey logic.")
      "Scikit-image is a collection of algorithms for image processing.")
     (license license:bsd-3)))
 
+(define-public python-sgp4
+  (package
+    (name "python-sgp4")
+    (version "2.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sgp4" version))
+       (sha256
+        (base32 "0dncp9i5b6afkg7f8mj9j0qzsp008b8v73yc0qkmizhpns7mvwvx"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-numpy" ,python-numpy)))
+    (home-page "https://github.com/brandon-rhodes/python-sgp4")
+    (synopsis "Track earth satellite TLE orbits using SGP4")
+    (description
+     "This package provides a Python implementation of the most recent version
+of the SGP4 satellite tracking algorithm.")
+    (license license:expat)))
+
 (define-public python-pandas
   (package
     (name "python-pandas")