diff mbox series

[bug#42876] gnu: Add kxstitch.

Message ID 20200815202344.10272-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#42876] gnu: Add kxstitch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Christopher Baines Aug. 15, 2020, 8:23 p.m. UTC
* gnu/packages/kde-utils.scm (kxstitch): New variable.
---
 gnu/packages/kde-utils.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Mathieu Othacehe Aug. 16, 2020, 7:22 a.m. UTC | #1
Hello Christopher,

> * gnu/packages/kde-utils.scm (kxstitch): New variable.

This looks fine, feel free to proceed!

Thanks,

Mathieu
Christopher Baines Aug. 16, 2020, 10:20 a.m. UTC | #2
Mathieu Othacehe writes:

> Hello Christopher,
>
>> * gnu/packages/kde-utils.scm (kxstitch): New variable.
>
> This looks fine, feel free to proceed!

Thanks for taking a look, I've pushed this as
f27a7e41568c0ae47b8c9a34c4f7e628e97d6c46 now.

Thanks again,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 3c0eb09745..642a5bbea6 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -24,6 +24,8 @@ 
   #:use-module (guix packages)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages imagemagick)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages kde)
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages kde-plasma)
@@ -297,6 +299,34 @@  Almost completely customizable, Krusader is very user friendly, fast and looks
 great on your desktop.")
     (license license:gpl2+)))
 
+(define-public kxstitch
+  (package
+    (name "kxstitch")
+    (version "2.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/kxstitch/" version
+                           "/kxstitch-" version ".tar.xz"))
+       (sha256
+        (base32 "1q6blvcqz6hxdfrkdi0fplmz7rmk3im56kpp68r0yrivhx3hn8sc"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("ktexteditor" ,ktexteditor)
+       ("imagemagick" ,imagemagick)
+       ("qtbase" ,qtbase)
+       ("qtx11extras" ,qtx11extras)))
+    (home-page "https://kde.org/applications/en/graphics/org.kde.kxstitch")
+    (synopsis "Create and print cross stitch patterns")
+    (description
+     "KXStitch allows creating and printing cross stitch patterns, which can
+either be created or generated from a image.")
+    (license license:gpl2+)))
+
 (define-public okteta
   (package
     (name "okteta")
@@ -510,3 +540,4 @@  It can quickly remove temporary information, such as web page cookies,
 browser history, or the list of recently-opened documents.  It helps provide
 additional privacy on a system shared between multiple users.")
     (license license:lgpl2.0+ )))
+<