diff mbox series

[bug#42807,v2,1/2] gnu: darktable: Update to 3.2.1.

Message ID 20200813145916.38243-1-monego@posteo.net
State Accepted
Headers show
Series [bug#42807,v2,1/2] gnu: darktable: Update to 3.2.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego Aug. 13, 2020, 2:59 p.m. UTC
* gnu/packages/photo.scm (darktable): Update to 3.2.1.
---
Edited description for GCC error and added more comments about optional dependencies
 gnu/packages/photo.scm | 30 ++++++++++++++++--------------
 1 file changed, 16 insertions(+), 14 deletions(-)

Comments

Ludovic Courtès Sept. 4, 2020, 9:06 a.m. UTC | #1
Hi,

Vinicius Monego <monego@posteo.net> skribis:

> * gnu/packages/photo.scm (darktable): Update to 3.2.1.

[...]

> * gnu/packages/photo.scm (darktable)[inputs]: Add libavif, ocl-icd.
> [arguments]: Set LD_LIBRARY_PATH for OpenCL.
> [supported-systems]: Remove i686 which is not supported anymore.

Thanks, applied!

> +             (wrap-program (string-append (assoc-ref outputs "out")
> +                                          "/bin/darktable")
> +               ;; For GtkFileChooserDialog.
> +               `("GSETTINGS_SCHEMA_DIR" =
> +                 (,(string-append (assoc-ref inputs "gtk+")
> +                                  "/share/glib-2.0/schemas")))
> +               ;; For libOpenCL.so.
> +               `("LD_LIBRARY_PATH" =
> +                 (,(string-append (assoc-ref inputs "ocl-icd")
> +                                  "/lib"))))

It’s weird that LD_LIBRARY_PATH needs to be specified here.  Isn’t the
binary already linked against libOpenCL?  If so, it should have it in
as NEEDed and its its RUNPATH, no?

Ludo’.
Vinicius Monego Sept. 5, 2020, 6:17 p.m. UTC | #2
Ludovic Courtès writes:

> Isn’t the binary already linked against libOpenCL?

It's not linked. libOpenCL is dynamically loaded. See
src/common/dlopencl.c.
diff mbox series

Patch

diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index abdb751a5a..688de5c460 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -465,7 +465,7 @@  photographic equipment.")
 (define-public darktable
   (package
     (name "darktable")
-    (version "3.0.2")
+    (version "3.2.1")
     (source
      (origin
        (method url-fetch)
@@ -473,7 +473,7 @@  photographic equipment.")
              "https://github.com/darktable-org/darktable/releases/"
              "download/release-" version "/darktable-" version ".tar.xz"))
        (sha256
-        (base32 "1yrnkw8c47kmy2x6m1xp69hwyk02xyc8pd9kvcmyj54lzrhzdfka"))))
+        (base32 "035rvqmw386hm0jpi14lf4dnpr5rjkalzjkyprqh42nwi3m86dkf"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ; there are no tests
@@ -482,6 +482,8 @@  photographic equipment.")
        (modify-phases %standard-phases
          (add-before 'configure 'prepare-build-environment
            (lambda* (#:key inputs #:allow-other-keys)
+             ;; Rawspeed fails to build with GCC due to OpenMP error:
+             ;; "undefined reference to `GOMP_loop_nonmonotonic_dynamic_next'"
              (setenv "CC" "clang") (setenv "CXX" "clang++")
              ;; Darktable looks for opencl-c.h in the LLVM dir. Guix installs
              ;; it to the Clang dir. We fix this by patching CMakeLists.txt.
@@ -523,36 +525,36 @@  photographic equipment.")
        ("po4a" ,po4a)))
     (inputs
      `(("cairo" ,cairo)
-       ("colord-gtk" ,colord-gtk)
-       ("cups" ,cups)
+       ("colord-gtk" ,colord-gtk) ;optional, for color profile support
+       ("cups" ,cups) ;optional, for printing support
        ("curl" ,curl)
        ("dbus-glib" ,dbus-glib)
        ("exiv2" ,exiv2)
        ("freeimage" ,freeimage)
-       ("gmic" ,gmic)
+       ("gmic" ,gmic) ;optional, for HaldcLUT support
        ("graphicsmagick" ,graphicsmagick)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gtk+" ,gtk+)
        ("ilmbase" ,ilmbase)
-       ("iso-codes" ,iso-codes)
+       ("iso-codes" ,iso-codes) ;optional, for language names in the preferences
        ("json-glib" ,json-glib)
        ("lcms" ,lcms)
-       ("lensfun" ,lensfun)
-       ("libgphoto2" ,libgphoto2)
+       ("lensfun" ,lensfun) ;optional, for the lens distortion plugin
+       ("libgphoto2" ,libgphoto2) ;optional, for camera tethering
        ("libjpeg" ,libjpeg-turbo)
        ("libomp" ,libomp)
        ("libpng" ,libpng)
        ("librsvg" ,librsvg)
-       ("libsecret" ,libsecret)
+       ("libsecret" ,libsecret) ;optional, for storing passwords
        ("libsoup" ,libsoup)
        ("libtiff" ,libtiff)
-       ("libwebp" ,libwebp)
+       ("libwebp" ,libwebp) ;optional, for WebP support
        ("libxml2" ,libxml2)
        ("libxslt" ,libxslt)
-       ("lua" ,lua) ;for plugins
-       ("openexr" ,openexr)
-       ("openjpeg" ,openjpeg)
-       ("osm-gps-map" ,osm-gps-map)
+       ("lua" ,lua) ;optional, for plugins
+       ("openexr" ,openexr) ;optional, for EXR import/export
+       ("openjpeg" ,openjpeg) ;optional, for JPEG2000 export
+       ("osm-gps-map" ,osm-gps-map) ;optional, for geotagging view
        ("pugixml" ,pugixml)
        ("python-jsonschema" ,python-jsonschema)
        ("sqlite" ,sqlite)))