diff mbox series

[bug#42767] gnu: Add rttr.

Message ID 20200808175320.12200-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#42767] gnu: Add rttr. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder Aug. 8, 2020, 5:53 p.m. UTC
* gnu/packages/cpp.scm (rttr): New variable.
---
A newer version of kdenlive needs this.

 gnu/packages/cpp.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

2.28.0

Comments

Mathieu Othacehe Aug. 10, 2020, 9:34 a.m. UTC | #1
Hello Michael,

Thanks for this patch. Did you change something to the way you are
sending patches? I have troubles to apply them, with errors such as:

--8<---------------cut here---------------start------------->8---
Applying: gnu: Add rttr.
Using index info to reconstruct a base tree...
M	gnu/packages/cpp.scm
error: patch failed: gnu/packages/cpp.scm:82
error: gnu/packages/cpp.scm: patch does not apply
error: Did you hand edit your patch?
--8<---------------cut here---------------end--------------->8---

> +    (home-page "https://github.com/rttrorg/rttr/")

This field is traditionally at the end of the package definition, right
before synopsis.

> +    (source
> +     '(#:tests? #f                      ; TODO

You could elaborate on why they are not enabled. Something to fix in particular?

> +       #:configure-flags
> +         '("-DBUILD_UNIT_TESTS=OFF"
> +           "-DBUILD_DOCUMENTATION=OFF")))
> +    (native-inputs `(("pkg-config" ,pkg-config)))
> +    (synopsis "C++ Reflection Library")
> +    (description
> +     "RTTR stands for Run Time Type Reflection. It describes the ability of a
> +computer program to introspect and modify an object at runtime. It is also the
> +name of the library itself, which is written in C++ and released as open
> +source library.")

There are a couple of linting warnings on this description. No need to
mention that it's open source :).

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 5e83bb69f6..9ff4dc864b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -82,7 +83,35 @@  strings, configuration, bit streams, threading, translation, and cross-platform
 operating system functions.")
     (license license:zlib)))
 
+(define-public rttr
+  (package
+    (name "rttr")
+    (version "0.9.6")
+    (home-page "https://github.com/rttrorg/rttr/")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "1yxad8sj40wi75hny8w6imrsx8wjasjmsipnlq559n4b6kl84ijp"))
+       (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f                      ; TODO
+       #:configure-flags
+         '("-DBUILD_UNIT_TESTS=OFF"
+           "-DBUILD_DOCUMENTATION=OFF")))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (synopsis "C++ Reflection Library")
+    (description
+     "RTTR stands for Run Time Type Reflection. It describes the ability of a
+computer program to introspect and modify an object at runtime. It is also the
+name of the library itself, which is written in C++ and released as open
+source library.")
+    (license license:expat)))
+
 (define-public rct
   (let* ((commit "b3e6f41d9844ef64420e628e0c65ed98278a843a")
          (revision "2"))
--