diff mbox series

[bug#42732] gnu: Add age.

Message ID 20200806212606.28269-1-kuba@kadziolka.net
State New
Headers show
Series [bug#42732] gnu: Add age. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Maja Kądziołka Aug. 6, 2020, 9:26 p.m. UTC
* gnu/packages/crypto.scm (age): New variable.
---
 gnu/packages/crypto.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Leo Famulari Aug. 7, 2020, 2:06 a.m. UTC | #1
On Thu, Aug 06, 2020 at 11:26:06PM +0200, Jakub Kądziołka wrote:
> * gnu/packages/crypto.scm (age): New variable.

Nice! I've been looking forward to this program.

> +    (version "1.0.0-beta4")

I know it's been in development for 10 months, but we usually don't
include betas or release candidates in Guix, unless the project is
abandoned. I think that, in this case, we should wait a bit longer for
the final release.
Maja Kądziołka Aug. 7, 2020, 5:45 p.m. UTC | #2
On Thu, Aug 06, 2020 at 10:06:47PM -0400, Leo Famulari wrote:
> On Thu, Aug 06, 2020 at 11:26:06PM +0200, Jakub Kądziołka wrote:
> > * gnu/packages/crypto.scm (age): New variable.
> 
> Nice! I've been looking forward to this program.
> 
> > +    (version "1.0.0-beta4")
> 
> I know it's been in development for 10 months, but we usually don't
> include betas or release candidates in Guix, unless the project is
> abandoned. I think that, in this case, we should wait a bit longer for
> the final release.

Okay. Is the rest of the package fine? I doubt any of that will change
once the program gets a full release.

Regards,
Jakub Kądziołka
Leo Famulari Aug. 7, 2020, 6:14 p.m. UTC | #3
On Fri, Aug 07, 2020 at 07:45:56PM +0200, Jakub Kądziołka wrote:
> Okay. Is the rest of the package fine? I doubt any of that will change
> once the program gets a full release.

I would make sure that version of our Go crypto library package is equal
to or newer than the one in 'go.mod'.

In general, I had not tried packaging this yet due to the long-ish list
of dependencies in 'go.sum'. But it seems they are not actually used...

I'm also curious about the go-diff dependency in 'go.mod'. It's imported
in 'internal/format/format_gofuzz.go' so I'm surprised the compilation
succeeds without it.
Jelle Licht May 28, 2023, 10:02 p.m. UTC | #4
Master already has age@1.1.1, so I'm closing this.
diff mbox series

Patch

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 5532f7e9f8..1aa5127799 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1185,3 +1185,34 @@  length extension attacks supporting MD4, MD5, RIPEMD-160, SHA-0, SHA-1,
 SHA-256, SHA-512, and WHIRLPOOL hashes.")
       (home-page "https://github.com/iagox86/hash_extender")
       (license license:bsd-3))))
+
+(define-public age
+  (package
+    (name "age")
+    (version "1.0.0-beta4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/FiloSottile/age")
+                     (commit (string-append "v" version))))
+              (sha256
+                (base32
+                  "0pp6zn4rdypyxn1md9ppisiwiapkfkbh08rzfl3qwn0998wx6gnb"))
+              (file-name (git-file-name name version))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "filippo.io/age/cmd/..."
+       #:unpack-path "filippo.io/age"
+       #:install-source? #f))
+    (inputs
+     `(("x-crypto" ,go-golang-org-x-crypto)))
+    (synopsis "Encrypt files with a password or public key")
+    (description "@command{age} is a simple, modern and secure file encryption
+tool. It features small explicit keys, no config options, and UNIX-style
+composability.
+
+Files can be encrypted with passphrases, as well as with age-specific or SSH
+public keys. A single encrypted container can be efficiently encrypted to
+multiple recipients.")
+    (home-page "https://age-encryption.org/")
+    (license license:bsd-3)))