diff mbox series

[bug#42722,4/4] gnu: Add ghc-mtl-prelude.

Message ID 20200805155725.19931-4-brown121407@posteo.ro
State New
Headers show
Series Add some Haskell packages. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alexandru-Sergiu Marton Aug. 5, 2020, 3:57 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-mtl-prelude): New variable.
---
 gnu/packages/haskell-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 1c2f863adf..3577b8f1ff 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8026,6 +8026,36 @@  Therefore, you may have to declare @code{import Control.Monad.Except ()} at
 the top of your file to get all of the ExceptT instances in scope.")
     (license license:bsd-3)))
 
+(define-public ghc-mtl-prelude
+  (package
+    (name "ghc-mtl-prelude")
+    (version "2.0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/mtl-prelude/mtl-prelude-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0cqjl0mcnj6qgx46qxjygndzlgch4mc0q0sm3wbd4fynjfhdv9n4"))))
+    (build-system haskell-build-system)
+    (home-page
+     "https://github.com/nikita-volkov/mtl-prelude")
+    (synopsis
+     "Reexports of most definitions from \"mtl\" and \"transformers\"")
+    (description
+     "This package only exports definitions from the \"mtl\" and
+\"transformers\" libraries.  Unlike every module of \"mtl\" it does not
+reexport @code{Control.Monad} and @code{Control.Monad.Fix}.  In combination
+with the @url{base-prelude, http://hackage.haskell.org/package/base-prelude}
+library, this should give you a quite rich prelude.  The @code{2.*} versions
+are restricted by the feature set of @code{mtl-2.2} and
+@code{transformers-0.4}, however they provide support for newer versions of
+those libraries as well.")
+    (license license:expat)))
+
 (define-public ghc-murmur-hash
   (package
     (name "ghc-murmur-hash")