diff mbox series

[bug#42722,1/4] gnu: Add ghc-quickcheck-text.

Message ID 20200805155725.19931-1-brown121407@posteo.ro
State New
Headers show
Series Add some Haskell packages. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alexandru-Sergiu Marton Aug. 5, 2020, 3:57 p.m. UTC
* gnu/packages/haskell-check.scm (ghc-quickcheck-text): New variable.
---
 gnu/packages/haskell-check.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index c2cffbad9e..0c988534d4 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
 ;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -485,6 +486,33 @@  testing Unicode-related software.")
 use HUnit assertions as QuickCheck properties.")
     (license license:expat)))
 
+(define-public ghc-quickcheck-text
+  (package
+    (name "ghc-quickcheck-text")
+    (version "0.1.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/quickcheck-text/quickcheck-text-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "02dbs0k6igmsa1hcw8yfvp09v7038vp4zlsp9706km3cmswgshj4"))))
+    (build-system haskell-build-system)
+    (inputs `(("ghc-quickcheck" ,ghc-quickcheck)))
+    (home-page
+     "https://github.com/olorin/quickcheck-text")
+    (synopsis "Alternative arbitrary instance for Text")
+    (description
+     "The usual
+@url{https://hackage.haskell.org/package/quickcheck-instances, Arbitrary
+instance for Text} only has single-byte instances and so isn't an ideal
+representation of a valid UTF-8 character.  This package has generators for
+one-, two- and three-byte UTF-8 characters (all that are currently in use).")
+    (license license:expat)))
+
 (define-public ghc-quickcheck
   (package
     (name "ghc-quickcheck")