diff mbox series

[bug#42682,1/2] gnu: Add python-hjson.

Message ID 20200802204910.15356-1-tona_kosmicznego_smiecia@interia.pl
State New
Headers show
Series Qmk cli | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jan Wielkiewicz Aug. 2, 2020, 8:49 p.m. UTC
* gnu/packages/python-xyz.scm (python-hjson): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Mathieu Othacehe Aug. 3, 2020, 8:21 a.m. UTC | #1
Hello Jan,

Thanks for this patch. Please make sure to run the linter that reports
two warnings here.

> +(define-public python-hjson
> +  (package
> +   (name "python-hjson")
> +   (version "3.0.1")
> +   (source
> +    (origin
> +     (method url-fetch)
> +     (uri (pypi-uri "hjson" version))
> +     (sha256
> +      (base32
> +       "1yaimcgz8w0ps1wk28wk9g9zdidp79d14xqqj9rjkvxalvx2f5qx"))))
> +   (build-system python-build-system)
> +   (arguments
> +    '(#:tests? #f)) ; no tests
> +   (home-page "http://github.com/hjson/hjson-py")
> +   (synopsis "User interface for JSON.")
> +   (description "Hjson, a user interface for JSON.")

You need to elaborate on that with at least two or three sentences,
explaining what is this user interface and what does it bring.

Thanks,

Mathieu
Jan Wielkiewicz Aug. 3, 2020, 12:28 p.m. UTC | #2
Dnia 2020-08-03, o godz. 10:21:11
Mathieu Othacehe <othacehe@gnu.org> napisał(a):

> 
> Hello Jan,
> 
> Thanks for this patch. Please make sure to run the linter that reports
> two warnings here.
Okay. I'll check that.
> 
> You need to elaborate on that with at least two or three sentences,
> explaining what is this user interface and what does it bring.
To be honest, I'm not sure what they mean by "user interface to JSON".
They vaguely explain this on their website https://hjson.github.io/
I'm also not sure if I'm permited to just copy and paste text from
their website because of copyright.
My English is also sloppy sometimes and I fail to write meaningful
description about too abstract things.
I can try diving in and check what it does, but I don't have any
experience with Python.

> Thanks,
> 
> Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ab0b12383..316865ddf1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -83,6 +83,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
+;;; Copyright © 2020 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21298,3 +21299,22 @@  and have a maximum lifetime built-in.")
      "This package contains a small collection of test tool plugins for
 @code{nose2} and @code{flake8}.")
     (license license:asl2.0)))
+
+(define-public python-hjson
+  (package
+   (name "python-hjson")
+   (version "3.0.1")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (pypi-uri "hjson" version))
+     (sha256
+      (base32
+       "1yaimcgz8w0ps1wk28wk9g9zdidp79d14xqqj9rjkvxalvx2f5qx"))))
+   (build-system python-build-system)
+   (arguments
+    '(#:tests? #f)) ; no tests
+   (home-page "http://github.com/hjson/hjson-py")
+   (synopsis "User interface for JSON.")
+   (description "Hjson, a user interface for JSON.")
+   (license license:expat)))