diff mbox series

[bug#42658,1/2] gnu: android: export android-libcutils

Message ID 20200801201625.27996-1-GNUtoo@cyberdimension.org
State Accepted
Headers show
Series [bug#42658,1/2] gnu: android: export android-libcutils | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Denis 'GNUtoo' Carikli Aug. 1, 2020, 8:16 p.m. UTC
Android's libcutils is used by many Android components, and as Guix can be
used to bulid Android components, it is useful to export it as it can then
be reused as an input to packages being developped outside of the Guix
source code repository.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
 gnu/packages/android.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Mathieu Othacehe Aug. 3, 2020, 7:16 a.m. UTC | #1
Hello,

> Android's libcutils is used by many Android components, and as Guix can be
> used to bulid Android components, it is useful to export it as it can then
> be reused as an input to packages being developped outside of the Guix
> source code repository.

This looks fine. I pushed those two patches with edited commit
messages. For future reference, very similar patches can be send in the
same serie :).

Thanks,

Mathieu
Denis 'GNUtoo' Carikli Aug. 5, 2020, 6:20 a.m. UTC | #2
On Mon, 03 Aug 2020 09:16:16 +0200
Mathieu Othacehe <othacehe@gnu.org> wrote:

> Hello,
Hi,

> This looks fine. I pushed those two patches with edited commit
> messages. 
Thanks a lot. I'll probably have more patches that I need to send it
soon but I need to find a faster way to test them.

> For future reference, very similar patches can be send in
> the same serie :).

How do I do that? I used the following command to send the patch:
> git send-email --to="guix-patches@gnu.org" \
> 	--cc="Julien Lepiller <julien@lepiller.eu>" \
> 	--cc="Danny Milosavljevic <dannym@scratchpost.org>" \
> 	0001-gnu-android-export-android-libcutils.patch \
> 	0002-gnu-android-export-android-liblog.patch \
> 	${sentinel}

Do I need to use --compose?

Denis.
Mathieu Othacehe Aug. 5, 2020, 7:40 a.m. UTC | #3
Hello,

> How do I do that? I used the following command to send the patch:
>> git send-email --to="guix-patches@gnu.org" \
>> 	--cc="Julien Lepiller <julien@lepiller.eu>" \
>> 	--cc="Danny Milosavljevic <dannym@scratchpost.org>" \
>> 	0001-gnu-android-export-android-libcutils.patch \
>> 	0002-gnu-android-export-android-liblog.patch \
>> 	${sentinel}

Each time a mail is sent to "guix-patches@gnu.org" a new bug ticket is
created. You should first send either the cover letter or the first
patch, and then send all the subsequent patches to NNN@debbugs.gnu.org
where NNN is the ticket number created when the first patch is sent.

See the bottom of
https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html for
further explications.

Thanks,

Mathieu
Denis 'GNUtoo' Carikli Aug. 5, 2020, 9:11 a.m. UTC | #4
On Wed, 05 Aug 2020 09:40:25 +0200
Mathieu Othacehe <othacehe@gnu.org> wrote:
> Each time a mail is sent to "guix-patches@gnu.org" a new bug ticket is
> created. You should first send either the cover letter or the first
> patch, and then send all the subsequent patches to NNN@debbugs.gnu.org
> where NNN is the ticket number created when the first patch is sent.
> 
> See the bottom of
> https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html for
> further explications.
Thanks a lot.

I read that part in the manual some time ago but I didn't think of
(ab)using it in this way to get the intended result.

Denis.
diff mbox series

Patch

diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 0fb4330d3e..af2b817298 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -229,7 +229,7 @@  in Main, System, Radio and Events sub-logs.")
 various Android core host applications.")
     (license license:asl2.0)))
 
-(define android-libcutils
+(define-public android-libcutils
   (package
     (name "android-libcutils")
     (version (android-platform-version))