diff mbox series

[bug#42619,v2,2/2] gnu: poetry: Fix problems with some dependencies.

Message ID 20200731114441.27096-2-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42619,v2,1/2] gnu: python-cleo: Update to 0.8.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 31, 2020, 11:44 a.m. UTC
* gnu/packages/python-xyz.scm (poetry)
[arguments]: Modify the required versions of python-tomlkit, python-clikit
and python-cleo.
---
 gnu/packages/python-xyz.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Kei Kebreau Aug. 5, 2020, 8:10 p.m. UTC | #1
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/python-xyz.scm (poetry)
> [arguments]: Modify the required versions of python-tomlkit, python-clikit
> and python-cleo.
> ---
>  gnu/packages/python-xyz.scm | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 0b6a35401a..937b801065 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -12402,7 +12402,12 @@ database, file, dict stores.  Cachy supports python versions 2.7+ and 3.2+.")
>               (substitute* "setup.py"
>                 ;; poetry won't update version as 21.0.0 relies on python > 3.6
>                 (("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")
> -               (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0"))
> +               (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")
> +               ;; Reported upstream:
> +               ;; <https://github.com/python-poetry/poetry/issues/2752>.
> +               (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")
> +               (("cleo>=0.7.6,<0.8.0") "cleo>=0.7.6,<0.9.0")
> +               (("clikit>=0.4.2,<0.5.0") "clikit>=0.4.2,<0.7.0"))
>               #t)))))
>      (propagated-inputs
>       `(("python-cachecontrol" ,python-cachecontrol)

LGTM!  They've been pushed to master as 993391c0e1 and fc45f2fcf8.

Thanks,
Kei
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0b6a35401a..937b801065 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12402,7 +12402,12 @@  database, file, dict stores.  Cachy supports python versions 2.7+ and 3.2+.")
              (substitute* "setup.py"
                ;; poetry won't update version as 21.0.0 relies on python > 3.6
                (("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")
-               (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0"))
+               (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")
+               ;; Reported upstream:
+               ;; <https://github.com/python-poetry/poetry/issues/2752>.
+               (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")
+               (("cleo>=0.7.6,<0.8.0") "cleo>=0.7.6,<0.9.0")
+               (("clikit>=0.4.2,<0.5.0") "clikit>=0.4.2,<0.7.0"))
              #t)))))
     (propagated-inputs
      `(("python-cachecontrol" ,python-cachecontrol)