diff mbox series

[bug#42364,v3] gnu: Add python-robber.

Message ID 20200730094015.12575-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42364,v3] gnu: Add python-robber. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 30, 2020, 9:40 a.m. UTC
* gnu/packages/python-xyz.scm (python-robber): New variable.
---
 gnu/packages/python-check.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Ludovic Courtès Sept. 24, 2020, 3:49 p.m. UTC | #1
Hi,

Tanguy Le Carrour <tanguy@bioneland.org> skribis:

> * gnu/packages/python-xyz.scm (python-robber): New variable.

[...]

> +    (synopsis "BDD / TDD assertion library for Python")
> +    (description "Robber is a BDD / TDD assertion library for Python.")

I tweaked these and applied, thanks!

Ludo’.
Tanguy LE CARROUR Sept. 27, 2020, 1:39 p.m. UTC | #2
Le 09/24, Ludovic Courtès a écrit :
> Hi,
> 
> Tanguy Le Carrour <tanguy@bioneland.org> skribis:
> 
> > * gnu/packages/python-xyz.scm (python-robber): New variable.
> 
> [...]
> 
> > +    (synopsis "BDD / TDD assertion library for Python")
> > +    (description "Robber is a BDD / TDD assertion library for Python.")
> 
> I tweaked these and applied, thanks!

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 51b864957f..aa00a35d23 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -889,3 +889,27 @@  any Python VM with basically no runtime overhead.")
     ;; Foundation License version 2: stdlib-samples/*, mypyc/lib-rt/pythonsupport.h and
     ;; mypyc/lib-rt/getargs.c
     (license (list license:expat license:psfl))))
+
+(define-public python-robber
+  (package
+    (name "python-robber")
+    (version "1.1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "robber" version))
+              (sha256
+               (base32
+                "0xp5csgv2g9q38hscml6bc5i1nm4xy5lzqqiimm2drxsf0hw2nq5"))))
+    (build-system python-build-system)
+    ;; There are no tests in the tarball downloaded from PyPI.
+    ;; The last version tagged in Github (0.1.0) is older than the one on PyPI.
+    ;; Reported upstream: <https://github.com/vesln/robber.py/issues/20>.
+    (arguments '(#:tests? #f))
+    (propagated-inputs
+     `(("python-mock" ,python-mock)
+       ("python-termcolor" ,python-termcolor)))
+    ;; URL of the fork used to generate the package available on PyPI.
+    (home-page "https://github.com/EastAgile/robber.py")
+    (synopsis "BDD / TDD assertion library for Python")
+    (description "Robber is a BDD / TDD assertion library for Python.")
+    (license license:expat)))