diff mbox series

[bug#42584] gnu: bison: Mention yacc in the description.

Message ID 20200728162501.30030-1-kuba@kadziolka.net
State Accepted
Headers show
Series [bug#42584] gnu: bison: Mention yacc in the description. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Maja Kądziołka July 28, 2020, 4:25 p.m. UTC
This should help the user find the package if the goal is to satisfy a
dependency on yacc.

* gnu/packages/bison.scm (bison)[synopsis, description]: Explain
  compatibility with Yacc.
---

Inspired #42474. Sending to the mailinglist for feedback, since I'm not
quite sure of the wording here.

 gnu/packages/bison.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

Comments

vasilii.smirnov--- via Guix-patches" via July 28, 2020, 4:45 p.m. UTC | #1
Jakub,

Jakub Kądziołka 写道:
> -    (synopsis "Parser generator")
> +    (synopsis "Yacc-compatible parser generator")

Sounds good to me.

> +Bison also provides an implementation of Yacc, as specified by 
> POSIX.")

Maybe use @command{yacc} here since that's what triggers ‘POSIX 
mode’, but I can go either way.

Thanks!

T G-R
Maja Kądziołka July 30, 2020, 12:32 a.m. UTC | #2
On Tue, Jul 28, 2020 at 06:45:57PM +0200, Tobias Geerinckx-Rice wrote:
> Jakub,
> 
> Jakub Kądziołka 写道:
> > -    (synopsis "Parser generator")
> > +    (synopsis "Yacc-compatible parser generator")
> 
> Sounds good to me.
> 
> > +Bison also provides an implementation of Yacc, as specified by POSIX.")
> 
> Maybe use @command{yacc} here since that's what triggers ‘POSIX mode’, but I
> can go either way.

Are you suggesting

| Bison also provides an implementation of @command{yacc}, as specified by POSIX.")

or some more elaborate re-wording? ;)

Regards,
Jakub Kądziołka
Maja Kądziołka July 30, 2020, 12:55 a.m. UTC | #3
On Thu, Jul 30, 2020 at 02:32:44AM +0200, Jakub Kądziołka wrote:
> On Tue, Jul 28, 2020 at 06:45:57PM +0200, Tobias Geerinckx-Rice wrote:
> > Jakub,
> > 
> > Jakub Kądziołka 写道:
> > > -    (synopsis "Parser generator")
> > > +    (synopsis "Yacc-compatible parser generator")
> > 
> > Sounds good to me.
> > 
> > > +Bison also provides an implementation of Yacc, as specified by POSIX.")
> > 
> > Maybe use @command{yacc} here since that's what triggers ‘POSIX mode’, but I
> > can go either way.
> 
> Are you suggesting
> 
> | Bison also provides an implementation of @command{yacc}, as specified by POSIX.")
> 
> or some more elaborate re-wording? ;)

Thanks for your response on IRC, patch pushed :D

Regards,
Jakub Kądziołka
diff mbox series

Patch

diff --git a/gnu/packages/bison.scm b/gnu/packages/bison.scm
index 725f38263f..95a3ff5a23 100644
--- a/gnu/packages/bison.scm
+++ b/gnu/packages/bison.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -57,12 +58,14 @@ 
     (inputs `(("flex" ,flex)))
     (propagated-inputs `(("m4" ,m4)))
     (home-page "https://www.gnu.org/software/bison/")
-    (synopsis "Parser generator")
+    (synopsis "Yacc-compatible parser generator")
     (description
      "GNU Bison is a general-purpose parser generator.  It can build a
 deterministic or generalized LR parser from an annotated, context-free
 grammar.  It is versatile enough to have many applications, from parsers for
-simple tools through complex programming languages.")
+simple tools through complex programming languages.
+
+Bison also provides an implementation of Yacc, as specified by POSIX.")
     (license gpl3+)))
 
 (define-public bison-3.6