diff mbox series

[bug#42583,1/2] gnu: Add rnnoise.

Message ID 20200728144524.4674-1-mail@ambrevar.xyz
State Accepted
Headers show
Series [bug#42583,1/2] gnu: Add rnnoise. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Pierre Neidhardt July 28, 2020, 2:45 p.m. UTC
* gnu/packages/pulseaudio.scm (rnnoise): New variable.
---
 gnu/packages/pulseaudio.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)


base-commit: f2dc025edab09b2f1c6cdce521635d0f518134ee

Comments

Mathieu Othacehe Aug. 1, 2020, 7:15 a.m. UTC | #1
Hey Pierre,

> * gnu/packages/pulseaudio.scm (rnnoise): New variable.

This patch is marked 1/2, is there a second part?

Otherwise this looks fine!

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 58c7e5bd7d..e411cfa46c 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Amin Bandali <bandali@gnu.org>
+;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -33,6 +34,7 @@ 
   #:use-module (guix git-download)
   #:use-module (guix utils)
   #:use-module ((guix licenses) #:prefix l:)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
@@ -468,3 +470,36 @@  volume levels of the sinks (get, set, decrease, increase, toggle mute, etc).")
 PulseAudio server settings from the X11 system tray.  See the project
 README.md for a detailed list of features.")
     (license l:lgpl2.1+)))
+
+(define-public rnnoise
+  (package
+    (name "rnnoise")
+    (version "0.9")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/werman/noise-suppression-for-voice")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "18bq5b50xw3d4r1ildinafpg3isb9y216430h4mm9wr3ir7h76a7"))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; No tests.
+     '(#:tests? #f))
+    (inputs
+     `(;; TODO: Add VST to build the plugin.
+       ("pulseaudio" ,pulseaudio)))
+    (home-page "https://github.com/werman/noise-suppression-for-voice")
+    (synopsis "Real-time Noise suppression plugin based on Xiph's RNNoise")
+    (description "The plugin is meant to suppress a wide range of noise
+origins: computer fans, office, crowd, airplane, car, train, construction.
+
+Mild background noise is always suppressed, loud sounds, like
+clicking of mechanical keyboard, are suppressed while there is no voice
+however they are only reduced in volume when voice is present.
+
+The plugin is made to work with 1 or 2 channels (ladspa plugin),
+16 bit, 48000 Hz audio input.")
+    (license l:gpl3)))