diff mbox series

[bug#42573,2/2] gnu: python-clikit: Update to 0.6.2.

Message ID 20200728092817.10539-2-tanguy@bioneland.org
State Accepted
Headers show
Series gnu: python-clikit: Update to 0.6.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 28, 2020, 9:28 a.m. UTC
* gnu/packages/python-xyz.scm (python-clikit): Update to 0.6.2.
[arguments] Explicitly disable tests.
[propagated-inputs]: Add python-crashtest.
---
 gnu/packages/python-xyz.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Comments

Oleg Pykhalov July 29, 2020, 5:27 a.m. UTC | #1
Hi,

Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/python-xyz.scm (python-clikit): Update to 0.6.2.
> [arguments] Explicitly disable tests.
> [propagated-inputs]: Add python-crashtest.
> ---
>  gnu/packages/python-xyz.scm | 8 +++++---
>  1 file changed, 5 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 9294d3ff31..18bee90121 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -12180,17 +12180,19 @@ more, possibly remote, memcached servers.")

[…]

> +    (arguments '(#:tests? #f))  ; no test in the PyPI tarball

Could you take a look on a fetching source with ‘git-fetch’ and enabling
tests suite?

Thanks,
Oleg.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9294d3ff31..18bee90121 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12180,17 +12180,19 @@  more, possibly remote, memcached servers.")
 (define-public python-clikit
   (package
     (name "python-clikit")
-    (version "0.4.2")
+    (version "0.6.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "clikit" version))
        (sha256
         (base32
-         "1jnnr21hvzx4i29nbph1z96ympv0njiwyvngjq48w1q05133cwzn"))))
+         "0ngdkmb73gkp5y00q7r9k1cdlfn0wyzws2wrqlshc4hlkbdyabj4"))))
     (build-system python-build-system)
+    (arguments '(#:tests? #f))  ; no test in the PyPI tarball
     (propagated-inputs
-     `(("python-pastel" ,python-pastel)
+     `(("python-crashtest" ,python-crashtest)
+       ("python-pastel" ,python-pastel)
        ("python-pylev" ,python-pylev)))
     (home-page "https://github.com/sdispater/clikit")
     (synopsis "Group of utilities to build command line interfaces")