diff mbox series

[bug#42556] gnu: csvkit: Add missing input.

Message ID 20200727105154.29052-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42556] gnu: csvkit: Add missing input. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 27, 2020, 10:51 a.m. UTC
* gnu/packages/wireservice.scm (csvkit)[inputs]: Add python-text-unidecode.
---
 gnu/packages/wireservice.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Tanguy LE CARROUR July 27, 2020, 10:59 a.m. UTC | #1
I forgot to mention "why" this patch…
`csvkit` will be broken when the patch #42511 is integrated. This is a
side effect of the update of `python-slugify`.
Tanguy LE CARROUR July 27, 2020, 7:58 p.m. UTC | #2
Actually, I figured out (yes, I can be a bit slow) that it would make
more sense to have this patch in the same set as the patch that
introduces the problem: #42511.

Sorry for the noise!
diff mbox series

Patch

diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index e3bfe8d478..9451e24d33 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -215,7 +216,8 @@  for xls and xlsx files support to all @code{agate.Table} instances.")))
      `(("python-agate-dbf" ,python-agate-dbf)
        ("python-agate-excel" ,python-agate-excel)
        ("python-agate-sql" ,python-agate-sql)
-       ("python-six" ,python-six)))
+       ("python-six" ,python-six)
+       ("python-text-unidecode" ,python-text-unidecode)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases