diff mbox series

[bug#39028] gnu: Add python-asyncssh

Message ID 20200727083823.GA29891@zpidnp36
State Accepted
Headers show
Series [bug#39028] gnu: Add python-asyncssh | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Lars-Dominik Braun July 27, 2020, 8:38 a.m. UTC
Hi again,

since master now has python-cryptography==2.9, we can safely add
python-asyncssh without any custom patches. The attached patches first update
python-gssapi (a dependency) and then add python-asyncssh.

Cheers,
Lars

Comments

Christopher Baines Oct. 31, 2020, 9:38 p.m. UTC | #1
Lars-Dominik Braun <ldb@leibniz-psychology.org> writes:

> since master now has python-cryptography==2.9, we can safely add
> python-asyncssh without any custom patches. The attached patches first update
> python-gssapi (a dependency) and then add python-asyncssh.

Hi!

This looks good to me, I tweaked the module (ssh seemed more
appropriate) and indentation, and pushed to master as
48dec2e04efdc764e16828fb7837ca58064f3cbe.

Thanks,

Chris
diff mbox series

Patch

From 7e30a2e8d122daf5f7e7ba6eee92a69f3ed4f49f Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Tue, 28 Apr 2020 11:41:08 +0200
Subject: [PATCH 2/2] gnu: Add python-asyncssh.

* gnu/packages/python-xyz.scm (python-asyncssh): New variable.
---
 gnu/packages/python-xyz.scm | 40 +++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 490d35f197..f2d158773e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21059,3 +21059,43 @@  and have a maximum lifetime built-in.")
      "This package contains a small collection of test tool plugins for
 @code{nose2} and @code{flake8}.")
     (license license:asl2.0)))
+
+(define-public python-asyncssh
+  (package
+    (name "python-asyncssh")
+    (version "2.3.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "asyncssh" version))
+        (sha256
+          (base32
+            "0pi6npmsgx7l9r1qrfvg8mxx3i23ipff492xz4yhrw13f56a7ga4"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-cryptography" ,python-cryptography)
+       ("python-pyopenssl" ,python-pyopenssl)
+       ("python-gssapi" ,python-gssapi)
+       ("python-bcrypt" ,python-bcrypt)))
+    ;; required for test suite
+    (native-inputs
+     `(("openssh" ,openssh)
+       ("openssl" ,openssl)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'disable-tests
+           (lambda* _
+            (substitute* "tests/test_agent.py"
+              ;; Test fails for unknown reason
+              (("(.+)async def test_confirm" all indent)
+                (string-append indent "@unittest.skip('disabled by guix')\n"
+                 indent "async def test_confirm"))))))))
+    (home-page "https://asyncssh.readthedocs.io/")
+    (synopsis
+      "Asynchronous SSHv2 client and server library")
+    (description
+      "AsyncSSH is a Python package which provides an asynchronous client and
+server implementation of the SSHv2 protocol on top of the Python 3.6+ asyncio
+framework")
+    (license license:epl2.0)))
-- 
2.20.1