diff mbox series

[bug#42554,staging] gnu: qtbase: Provide debug symbols.

Message ID 20200726231921.5804-1-kuba@kadziolka.net
State Accepted
Headers show
Series [bug#42554,staging] gnu: qtbase: Provide debug symbols. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Maja Kądziołka July 26, 2020, 11:19 p.m. UTC
* gnu/packages/qt.scm (qtbase)[outputs]: Add "debug".
[arguments]: Add "-force-debug-info" to configure flags.
---
NOTE: This increases the size of qtbase:out by about 6 MB. I am working
on a core-updates patch that restores the original size.

 gnu/packages/qt.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Mathieu Othacehe Aug. 1, 2020, 7:39 a.m. UTC | #1
Hello Jakub,

> * gnu/packages/qt.scm (qtbase)[outputs]: Add "debug".
> [arguments]: Add "-force-debug-info" to configure flags.

This looks fine!

Thanks,

Mathieu
Maja Kądziołka Aug. 5, 2020, 12:17 a.m. UTC | #2
On Sat, Aug 01, 2020 at 09:39:41AM +0200, Mathieu Othacehe wrote:
> 
> Hello Jakub,
> 
> > * gnu/packages/qt.scm (qtbase)[outputs]: Add "debug".
> > [arguments]: Add "-force-debug-info" to configure flags.
> 
> This looks fine!

Thanks for your review, patch pushed to staging!

Regards,
Jakub Kądziołka
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 1cbf7991ab..94b45a5520 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -367,6 +367,7 @@  developers using C++ or QML, a CSS & JavaScript like language.")
                                   "zlib"))
                   #t)))))
     (build-system gnu-build-system)
+    (outputs '("out" "debug"))
     (propagated-inputs
      `(("mesa" ,mesa)
        ;; Use which the package, not the function
@@ -473,6 +474,9 @@  developers using C++ or QML, a CSS & JavaScript like language.")
                  "-opensource"
                  "-confirm-license"
 
+                 ;; Later stripped into the :debug output.
+                 "-force-debug-info"
+
                  ;; These features require higher versions of Linux than the
                  ;; minimum version of the glibc.  See
                  ;; src/corelib/global/minimum-linux_p.h.  By disabling these