diff mbox series

[bug#42511,v2,1/2] gnu: python-slugify: Update to 4.0.1.

Message ID 20200725172337.3609-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42511,v2,1/2] gnu: python-slugify: Update to 4.0.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 25, 2020, 5:23 p.m. UTC
* gnu/packages/patches/python-slugify-depend-on-unidecode.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/python-web.scm (python-slugify): Update to 4.0.1. [source] Drop patch.
---
 gnu/local.mk                                  |  1 -
 .../python-slugify-depend-on-unidecode.patch  | 22 -------------------
 gnu/packages/python-web.scm                   |  6 ++---
 3 files changed, 2 insertions(+), 27 deletions(-)
 delete mode 100644 gnu/packages/patches/python-slugify-depend-on-unidecode.patch

Comments

Pierre Langlois July 25, 2020, 5:59 p.m. UTC | #1
Hi Tanguy!

Tanguy Le Carrour writes:

> * gnu/packages/patches/python-slugify-depend-on-unidecode.patch: Delete file.
> * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
> * gnu/packages/python-web.scm (python-slugify): Update to 4.0.1. [source] Drop patch.
> ---
>  gnu/local.mk                                  |  1 -
>  .../python-slugify-depend-on-unidecode.patch  | 22 -------------------
>  gnu/packages/python-web.scm                   |  6 ++---
>  3 files changed, 2 insertions(+), 27 deletions(-)
>  delete mode 100644 gnu/packages/patches/python-slugify-depend-on-unidecode.patch
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index f2a7b6b984..bb9b03bb6f 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -1478,7 +1478,6 @@ dist_patch_DATA =						\
>    %D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch	\
>    %D%/packages/patches/python-robotframework-honor-source-date-epoch.patch \
>    %D%/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch	\
> -  %D%/packages/patches/python-slugify-depend-on-unidecode.patch	\
>    %D%/packages/patches/python2-subprocess32-disable-input-test.patch	\
>    %D%/packages/patches/python-tinycss2-flake8-compat.patch	\
>    %D%/packages/patches/python-unittest2-python3-compat.patch	\
> diff --git a/gnu/packages/patches/python-slugify-depend-on-unidecode.patch b/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
> deleted file mode 100644
> index 5ac749c19d..0000000000
> --- a/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
> +++ /dev/null
> @@ -1,22 +0,0 @@
> -diff --git a/setup.py b/setup.py
> -index 4800173..6bdd77f 100755
> ---- a/setup.py
> -+++ b/setup.py
> -@@ -14,8 +14,7 @@ url = 'https://github.com/un33k/python-slugify'
> - author = 'Val Neekman'
> - author_email = 'info@neekware.com'
> - license = 'MIT'
> --install_requires = ['text-unidecode>=1.3']
> --extras_require = {'unidecode': ['Unidecode>=1.1.1']}
> -+install_requires = ['Unidecode']
> -
> - classifiers = [
> -     'Development Status :: 5 - Production/Stable',
> -@@ -67,7 +66,6 @@ setup(
> -     author_email=author_email,
> -     packages=find_packages(exclude=EXCLUDE_FROM_PACKAGES),
> -     install_requires=install_requires,
> --    extras_require=extras_require,
> -     classifiers=classifiers,
> -     entry_points={'console_scripts': ['slugify=slugify.slugify:main']},
> - )

I remember adding this patch, without it csvkit doesn't build with the
following error:

```
starting phase `check'
running "python setup.py" with command "test" and parameters ()
running test
Searching for text-unidecode>=1.3
Reading https://pypi.org/simple/text-unidecode/
Download error on https://pypi.org/simple/text-unidecode/: [Errno -2] Name or service not known -- Some packages may not be found!
Couldn't find index page for 'text-unidecode' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.org/simple/
Download error on https://pypi.org/simple/: [Errno -2] Name or service not known -- Some packages may not be found!
No local packages or working download links found for text-unidecode>=1.3
error: Could not find suitable distribution for Requirement.parse('text-unidecode>=1.3')
command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test" failed with status 1
builder for `/gnu/store/1dmzhmc1miszbwy84s5bvn2pw2zjzgkv-csvkit-1.0.5.drv' failed with exit code 1
build of /gnu/store/1dmzhmc1miszbwy84s5bvn2pw2zjzgkv-csvkit-1.0.5.drv failed
View build log at '/var/log/guix/drvs/1d/mzhmc1miszbwy84s5bvn2pw2zjzgkv-csvkit-1.0.5.drv.bz2'.
guix build: error: build of `/gnu/store/1dmzhmc1miszbwy84s5bvn2pw2zjzgkv-csvkit-1.0.5.drv' failed
```

I'm not familiar enough with the python build/test process to know for
sure if this is an issue with csvkit or python-slugify. We could just
package the python-text-unidecode package, but AFAIU the
python-unidecode package we already have is equivalent so it should be
OK. But somehow csvkit's check procedure doesn't see that.

Should we keep this patch around? Or maybe somebody has a better idea of
what's going on? I realise now I should have added a comment here :-).

Thanks!
Pierre
Tanguy LE CARROUR July 27, 2020, 8:43 a.m. UTC | #2
Hi Pierre,

Le 07/25, Pierre Langlois a écrit :
> Tanguy Le Carrour writes:
> 
> > * gnu/packages/patches/python-slugify-depend-on-unidecode.patch: Delete file.
> […]
> I remember adding this patch, without it csvkit doesn't build […]
> I'm not familiar enough with the python build/test process to know for
> sure if this is an issue with csvkit or python-slugify. We could just
> package the python-text-unidecode package, but AFAIU the
> python-unidecode package we already have is equivalent so it should be
> OK. But somehow csvkit's check procedure doesn't see that.
> 
> Should we keep this patch around? Or maybe somebody has a better idea of
> what's going on? I realise now I should have added a comment here :-).

Thanks for raising the issue!
As we already have `python-text-unidecode`, I tried patching `csvkit` and
it builds again. But I haven't tried `csvkit` itself!
Does it sound like a proper solution to you?
Pierre Langlois July 27, 2020, 9:17 a.m. UTC | #3
Tanguy Le Carrour writes:

> Hi Pierre,
>
> Le 07/25, Pierre Langlois a écrit :
>> Tanguy Le Carrour writes:
>> 
>> > * gnu/packages/patches/python-slugify-depend-on-unidecode.patch: Delete file.
>> […]
>> I remember adding this patch, without it csvkit doesn't build […]
>> I'm not familiar enough with the python build/test process to know for
>> sure if this is an issue with csvkit or python-slugify. We could just
>> package the python-text-unidecode package, but AFAIU the
>> python-unidecode package we already have is equivalent so it should be
>> OK. But somehow csvkit's check procedure doesn't see that.
>> 
>> Should we keep this patch around? Or maybe somebody has a better idea of
>> what's going on? I realise now I should have added a comment here :-).
>
> Thanks for raising the issue!
> As we already have `python-text-unidecode`, I tried patching `csvkit` and
> it builds again. But I haven't tried `csvkit` itself!
> Does it sound like a proper solution to you?

Oh, I didn't realise we already had this package, yep, that sounds great
to me!

Thanks,
Pierre
Tanguy LE CARROUR July 27, 2020, 10:56 a.m. UTC | #4
Le 07/27, Pierre Langlois a écrit :
> Tanguy Le Carrour writes:
> > Le 07/25, Pierre Langlois a écrit :
> >> Tanguy Le Carrour writes:
> >> 
> >> > * gnu/packages/patches/python-slugify-depend-on-unidecode.patch: Delete file.
> >> […]
> >> I remember adding this patch, without it csvkit doesn't build […]
> >> I'm not familiar enough with the python build/test process to know for
> >> sure if this is an issue with csvkit or python-slugify. We could just
> >> package the python-text-unidecode package, but AFAIU the
> >> python-unidecode package we already have is equivalent so it should be
> >> OK. But somehow csvkit's check procedure doesn't see that.
> >> 
> >> Should we keep this patch around? Or maybe somebody has a better idea of
> >> what's going on? I realise now I should have added a comment here :-).
> >
> > Thanks for raising the issue!
> > As we already have `python-text-unidecode`, I tried patching `csvkit` and
> > it builds again. But I haven't tried `csvkit` itself!
> > Does it sound like a proper solution to you?
> 
> Oh, I didn't realise we already had this package, yep, that sounds great
> to me!

Submitted as #42556. I guess the commit message should contain "fix"…
but right now, `csvkit` is not (yet) broken.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index f2a7b6b984..bb9b03bb6f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1478,7 +1478,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch	\
   %D%/packages/patches/python-robotframework-honor-source-date-epoch.patch \
   %D%/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch	\
-  %D%/packages/patches/python-slugify-depend-on-unidecode.patch	\
   %D%/packages/patches/python2-subprocess32-disable-input-test.patch	\
   %D%/packages/patches/python-tinycss2-flake8-compat.patch	\
   %D%/packages/patches/python-unittest2-python3-compat.patch	\
diff --git a/gnu/packages/patches/python-slugify-depend-on-unidecode.patch b/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
deleted file mode 100644
index 5ac749c19d..0000000000
--- a/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
+++ /dev/null
@@ -1,22 +0,0 @@ 
-diff --git a/setup.py b/setup.py
-index 4800173..6bdd77f 100755
---- a/setup.py
-+++ b/setup.py
-@@ -14,8 +14,7 @@ url = 'https://github.com/un33k/python-slugify'
- author = 'Val Neekman'
- author_email = 'info@neekware.com'
- license = 'MIT'
--install_requires = ['text-unidecode>=1.3']
--extras_require = {'unidecode': ['Unidecode>=1.1.1']}
-+install_requires = ['Unidecode']
- 
- classifiers = [
-     'Development Status :: 5 - Production/Stable',
-@@ -67,7 +66,6 @@ setup(
-     author_email=author_email,
-     packages=find_packages(exclude=EXCLUDE_FROM_PACKAGES),
-     install_requires=install_requires,
--    extras_require=extras_require,
-     classifiers=classifiers,
-     entry_points={'console_scripts': ['slugify=slugify.slugify:main']},
- )
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a202873fd0..a52220ff23 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3522,15 +3522,13 @@  Python.")
 (define-public python-slugify
   (package
     (name "python-slugify")
-    (version "3.0.4")
+    (version "4.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "python-slugify" version))
        (sha256
-        (base32 "0dv97yi5fq074q5qyqbin09pmi8ixg36caf5nkpw2bqkd8jh6pap"))
-       (patches
-        (search-patches "python-slugify-depend-on-unidecode.patch"))))
+        (base32 "0w22fapghmzk3xdasc4dn7h8sl58l08d1h5zbf72dh80drv1g9b9"))))
     (native-inputs
      `(("python-wheel" ,python-wheel)))
     (propagated-inputs