diff mbox series

[bug#42511,1/2] gnu: python-slugify: Update to 4.0.1.

Message ID 20200724081741.9341-1-tanguy@bioneland.org
State Accepted
Headers show
Series gnu: python-cookiecutter: Update to 1.7.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 24, 2020, 8:17 a.m. UTC
* gnu/packages/python-web.scm (python-slugify): Update to 4.0.1. [source] Drop patch.
* gnu/packages/patches/python-slugify-depend-on-unidecode.patch: Remove useless patch.
---
 .../python-slugify-depend-on-unidecode.patch  | 22 -------------------
 gnu/packages/python-web.scm                   |  6 ++---
 2 files changed, 2 insertions(+), 26 deletions(-)
 delete mode 100644 gnu/packages/patches/python-slugify-depend-on-unidecode.patch

Comments

Oleg Pykhalov July 25, 2020, 10:36 a.m. UTC | #1
Hi,

Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/python-web.scm (python-slugify): Update to 4.0.1. [source] Drop patch.
> * gnu/packages/patches/python-slugify-depend-on-unidecode.patch: Remove useless patch.
> ---
>  .../python-slugify-depend-on-unidecode.patch  | 22 -------------------

This patch should be also removed from gnu/local.mk file:
--8<---------------cut here---------------start------------->8---
$ make
make  all-recursive
make[1]: Entering directory '/home/oleg/src/guix-master'
Making all in po/guix
make[2]: Entering directory '/home/oleg/src/guix-master/po/guix'
make[2]: Leaving directory '/home/oleg/src/guix-master/po/guix'
Making all in po/packages
make[2]: Entering directory '/home/oleg/src/guix-master/po/packages'
make[2]: Leaving directory '/home/oleg/src/guix-master/po/packages'
make[2]: Entering directory '/home/oleg/src/guix-master'
Compiling Scheme modules...
make[2]: *** No rule to make target 'gnu/packages/patches/python-slugify-depend-on-unidecode.patch', needed by 'all-am'.  Stop.
...
make[2]: Leaving directory '/home/oleg/src/guix-master'
make[1]: *** [Makefile:5048: all-recursive] Error 1
make[1]: Leaving directory '/home/oleg/src/guix-master'
make: *** [Makefile:3487: all] Error 2

$ grep -RF python-slugify-depend-on-unidecode.patch .
./gnu/local.mk:  %D%/packages/patches/python-slugify-depend-on-unidecode.patch  \
...
--8<---------------cut here---------------end--------------->8---

[…]

Otherwise LGTM.

Could you send updated patch, please?

Thanks,
Oleg.
diff mbox series

Patch

diff --git a/gnu/packages/patches/python-slugify-depend-on-unidecode.patch b/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
deleted file mode 100644
index 5ac749c19d..0000000000
--- a/gnu/packages/patches/python-slugify-depend-on-unidecode.patch
+++ /dev/null
@@ -1,22 +0,0 @@ 
-diff --git a/setup.py b/setup.py
-index 4800173..6bdd77f 100755
---- a/setup.py
-+++ b/setup.py
-@@ -14,8 +14,7 @@ url = 'https://github.com/un33k/python-slugify'
- author = 'Val Neekman'
- author_email = 'info@neekware.com'
- license = 'MIT'
--install_requires = ['text-unidecode>=1.3']
--extras_require = {'unidecode': ['Unidecode>=1.1.1']}
-+install_requires = ['Unidecode']
- 
- classifiers = [
-     'Development Status :: 5 - Production/Stable',
-@@ -67,7 +66,6 @@ setup(
-     author_email=author_email,
-     packages=find_packages(exclude=EXCLUDE_FROM_PACKAGES),
-     install_requires=install_requires,
--    extras_require=extras_require,
-     classifiers=classifiers,
-     entry_points={'console_scripts': ['slugify=slugify.slugify:main']},
- )
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a202873fd0..a52220ff23 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3522,15 +3522,13 @@  Python.")
 (define-public python-slugify
   (package
     (name "python-slugify")
-    (version "3.0.4")
+    (version "4.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "python-slugify" version))
        (sha256
-        (base32 "0dv97yi5fq074q5qyqbin09pmi8ixg36caf5nkpw2bqkd8jh6pap"))
-       (patches
-        (search-patches "python-slugify-depend-on-unidecode.patch"))))
+        (base32 "0w22fapghmzk3xdasc4dn7h8sl58l08d1h5zbf72dh80drv1g9b9"))))
     (native-inputs
      `(("python-wheel" ,python-wheel)))
     (propagated-inputs