diff mbox series

[bug#42488] gnu: khal: Fix a failing test.

Message ID 20200723075043.19237-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42488] gnu: khal: Fix a failing test. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Tanguy LE CARROUR July 23, 2020, 7:50 a.m. UTC
* gnu/packages/calendar.scm (khal): [arguments] Fix a failing test.
---
 gnu/packages/calendar.scm | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Efraim Flashner July 23, 2020, 8:05 a.m. UTC | #1
Thanks, it's been bothering me that I couldn't upgrade that package.

Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 726687d488..53c73c969d 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -8,6 +8,7 @@ 
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com
 ;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -195,6 +196,12 @@  data units.")
              "doc/build/man/khal.1"
              (string-append (assoc-ref outputs "out") "/share/man/man1"))
             #t))
+        (add-before 'check 'fix-tests
+          (lambda _
+            ;; Reported upstream: <https://github.com/pimutils/khal/issues/947>.
+            (substitute* "tests/cli_test.py"
+             (("Invalid value for \"\\[ICS\\]\"") "Invalid value for \\'[ICS]\\'"))
+            #t))
         (replace 'check
           (lambda* (#:key inputs #:allow-other-keys)
             ;; The tests require us to choose a timezone.