diff mbox series

[bug#42364,v2] gnu: Add python-robber.

Message ID 20200722081440.21986-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42364,v2] gnu: Add python-robber. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 22, 2020, 8:14 a.m. UTC
* gnu/packages/python-check.scm (python-robber): New variable.
---
 gnu/packages/python-check.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Marius Bakke July 25, 2020, 3:40 p.m. UTC | #1
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/python-check.scm (python-robber): New variable.

[...]

> +    ;; The last version tagged in Github (0.1.0) is older than the one on PyPI.
> +    ;; Reported upstream: <https://github.com/vesln/robber.py/issues/20>.

Wow, it's concerning that someone just uploaded a fork on PyPI without
notifying the original author, yet reuses the original home page.

Even more so when there are no tags matching the uploaded tarball.

I think we should adjust the home page of this package to point to the
fork, and maybe add a comment explaining the situation.  WDYT?

Can you also add a copyright line for yourself in python-check.scm?

Thanks for tracking down this issue!
Tanguy LE CARROUR July 27, 2020, 8:26 a.m. UTC | #2
Hi Marius,


Le 07/25, Marius Bakke a écrit :
> Tanguy Le Carrour <tanguy@bioneland.org> writes:
> 
> > * gnu/packages/python-check.scm (python-robber): New variable.
> 
> [...]
> 
> > +    ;; The last version tagged in Github (0.1.0) is older than the one on PyPI.
> > +    ;; Reported upstream: <https://github.com/vesln/robber.py/issues/20>.
> 
> Wow, it's concerning that someone just uploaded a fork on PyPI without
> notifying the original author, yet reuses the original home page.

He might have tried, but… the original author's email address given on
PyPI does not exist any more!


> Even more so when there are no tags matching the uploaded tarball.
> 
> I think we should adjust the home page of this package to point to the
> fork, and maybe add a comment explaining the situation.  WDYT?

I've just send a email to the author of the last commit in the second
repo. Let's see what will happen!
In the worst case scenario, I can open a claim request on PyPI and fix
the mess myself. But let's hope I don't have to do that! ^_^'
Marius Bakke July 29, 2020, 10:23 p.m. UTC | #3
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> Hi Marius,
>
>
> Le 07/25, Marius Bakke a écrit :
>> Tanguy Le Carrour <tanguy@bioneland.org> writes:
>> 
>> > * gnu/packages/python-check.scm (python-robber): New variable.
>> 
>> [...]
>> 
>> > +    ;; The last version tagged in Github (0.1.0) is older than the one on PyPI.
>> > +    ;; Reported upstream: <https://github.com/vesln/robber.py/issues/20>.
>> 
>> Wow, it's concerning that someone just uploaded a fork on PyPI without
>> notifying the original author, yet reuses the original home page.
>
> He might have tried, but… the original author's email address given on
> PyPI does not exist any more!

Oh, right.  That makes sense.  :-)

>> Even more so when there are no tags matching the uploaded tarball.
>> 
>> I think we should adjust the home page of this package to point to the
>> fork, and maybe add a comment explaining the situation.  WDYT?
>
> I've just send a email to the author of the last commit in the second
> repo. Let's see what will happen!
> In the worst case scenario, I can open a claim request on PyPI and fix
> the mess myself. But let's hope I don't have to do that! ^_^'

I hope so too!  Meanwhile I think we can take the original patch you
sent, but adjust the home page to that of the fork.
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2e3cfe05c5..8c4af22fab 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -534,3 +534,26 @@  it, the declaration of a name's public export semantics are not separated from
 the implementation of that name.")
     (license (list license:asl2.0
                    license:lgpl3))))    ; only for setup_helpers.py
+
+(define-public python-robber
+  (package
+    (name "python-robber")
+    (version "1.1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "robber" version))
+              (sha256
+               (base32
+                "0xp5csgv2g9q38hscml6bc5i1nm4xy5lzqqiimm2drxsf0hw2nq5"))))
+    (build-system python-build-system)
+    ;; The last version tagged in Github (0.1.0) is older than the one on PyPI.
+    ;; Reported upstream: <https://github.com/vesln/robber.py/issues/20>.
+    ;; There are no tests in the tarball downloaded from PyPI.
+    (arguments '(#:tests? #f))
+    (propagated-inputs
+     `(("python-mock" ,python-mock)
+       ("python-termcolor" ,python-termcolor)))
+    (home-page "https://github.com/vesln/robber.py")
+    (synopsis "BDD / TDD assertion library for Python")
+    (description "Robber is a BDD / TDD assertion library for Python.")
+    (license license:expat)))