diff mbox series

[bug#42395,v2,1/2] gnu: Add python-mypy-extensions.

Message ID 20200716144012.28902-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42395,v2,1/2] gnu: Add python-mypy-extensions. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Tanguy LE CARROUR July 16, 2020, 2:40 p.m. UTC
* gnu/packages/python-check.scm (python-mypy-extensions): New variable.
---
 gnu/packages/python-check.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 200bce6ced..819ce21e09 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bionelang.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -451,3 +452,22 @@  analysing code quality.")
     (description "This package provides a library for replying fake data to
 Python software under test, when they make an HTTP query.")
     (license license:asl2.0)))
+
+(define-public python-mypy-extensions
+  (package
+    (name "python-mypy-extensions")
+    (version "0.4.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "mypy_extensions" version))
+        (sha256
+         (base32
+          "1a04qsk8hd1lqns8w1j7cr0vmvbhg450di5k1i16kqxkbf7q30id"))))
+    (build-system python-build-system)
+    (arguments `(#:tests? #f)); no tests
+    (home-page "https://github.com/python/mypy_extensions")
+    (synopsis "Experimental extensions for MyPy.")
+    (description "The @code{python-mypy-extensions} module defines experimental
+extensions to the standard 'typing' module that are supported by the mypy typechecker.")
+    (license license:expat)))