diff mbox series

[bug#42364] gnu: Add python-robber.

Message ID 20200715122832.9196-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#42364] gnu: Add python-robber. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR July 15, 2020, 12:28 p.m. UTC
* gnu/packages/python-xyz.scm (python-robber): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Marius Bakke July 21, 2020, 9:22 p.m. UTC | #1
Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/python-xyz.scm (python-robber): New variable.

Thanks!  As this appears to be a test library, can you move it to
python-check.scm?

[...]
  
> +(define-public python-robber
> +  (package
> +    (name "python-robber")
> +    (version "1.1.5")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "robber" version))
> +              (sha256
> +               (base32
> +                "0xp5csgv2g9q38hscml6bc5i1nm4xy5lzqqiimm2drxsf0hw2nq5"))))
> +    (build-system python-build-system)
> +    (arguments '(#:tests? #f))  ; no tests

There appears to be tests in the upstream repository:

  https://github.com/vesln/robber.py/tree/master/tests

Perhaps we should pull that instead of the PyPI release?

Otherwise LGTM.
Tanguy LE CARROUR July 22, 2020, 8:14 a.m. UTC | #2
Hi,

Le 07/21, Marius Bakke a écrit :
> Tanguy Le Carrour <tanguy@bioneland.org> writes:
> 
> > * gnu/packages/python-xyz.scm (python-robber): New variable.
> 
> Thanks!  As this appears to be a test library, can you move it to
> python-check.scm?

Would make sense, indeed! I'm sending a v2 for this.


> > +(define-public python-robber
> > +  (package
> > +    (name "python-robber")
> > +    (version "1.1.5")
> > +    (source (origin
> > +              (method url-fetch)
> > +              (uri (pypi-uri "robber" version))
> > +              (sha256
> > +               (base32
> > +                "0xp5csgv2g9q38hscml6bc5i1nm4xy5lzqqiimm2drxsf0hw2nq5"))))
> > +    (build-system python-build-system)
> > +    (arguments '(#:tests? #f))  ; no tests
> 
> There appears to be tests in the upstream repository:
> 
>   https://github.com/vesln/robber.py/tree/master/tests
> 
> Perhaps we should pull that instead of the PyPI release?

Yes, but… for an (yet) unknown reason, version 1.1.5 is not in the git
repo!? The last version is 0.1.0!?
I sent an email to the author mentioned on PyPI. I'm adding a comment on
this in the package definition.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 15d9e097c5..f6afb73fcb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3522,6 +3522,26 @@  designed to be used by Robot Framework and tools and libraries in its
 ecosystem, but can naturally be used also by other projects.")
     (license license:asl2.0)))
 
+(define-public python-robber
+  (package
+    (name "python-robber")
+    (version "1.1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "robber" version))
+              (sha256
+               (base32
+                "0xp5csgv2g9q38hscml6bc5i1nm4xy5lzqqiimm2drxsf0hw2nq5"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f))  ; no tests
+    (propagated-inputs
+     `(("python-mock" ,python-mock)
+       ("python-termcolor" ,python-termcolor)))
+    (home-page "https://github.com/vesln/robber.py")
+    (synopsis "BDD / TDD assertion library for Python")
+    (description "Robber is a BDD / TDD assertion library for Python.")
+    (license license:expat)))
+
 (define-public python-robotframework
   (package
     (name "python-robotframework")