diff mbox series

[bug#42362] gnu: Add font-catamaran.

Message ID 20200715105125.1861-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#42362] gnu: Add font-catamaran. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Arun Isaac July 15, 2020, 10:51 a.m. UTC
* gnu/packages/fonts.scm (font-catamaran): New variable.
---
 gnu/packages/fonts.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Efraim Flashner July 20, 2020, 1:26 p.m. UTC | #1
On Wed, Jul 15, 2020 at 04:21:25PM +0530, Arun Isaac wrote:
> * gnu/packages/fonts.scm (font-catamaran): New variable.
> ---
>  gnu/packages/fonts.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
> 
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index 38b342f770..048e27f8ff 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -1927,3 +1927,27 @@ languages, it contains Japanese characters, including Kana glyphs and more
>  than 5,300 Kanji glyphs, as well major international phonetic symbols,
>  operators and special symbols.")
>      (license (license:non-copyleft "file:///LICENSE_E"))))
> +
> +(define-public font-catamaran
> +  (let ((commit "7559b4906f9c9148fb22c6f89508c3053a78a296")
> +        (revision "1"))
> +    (package
> +      (name "font-catamaran")
> +      (version (git-version "20170622" revision commit))

This should be (git-version "0.0.0" revision commit)

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/VanillaandCream/Catamaran-Tamil")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> +           "1wpp41l7j2kpgnyavhgxcc5wp852a4wqsnwravn39gp980s84yxw"))))
> +      (build-system font-build-system)
> +      (home-page "https://github.com/VanillaandCream/Catamaran-Tamil")
> +      (synopsis "9 weight Tamil and Latin type")
> +      (description "Catamaran is a 9 weight Tamil and Latin type.  Catamaran
> +is a stylish type with a polished yet relaxed feel.  Its versatility makes it
> +suitable for a wide range of uses.")
> +      (license license:silofl1.1))))
> -- 

LGTM with the one change!
Arun Isaac July 22, 2020, 10:43 p.m. UTC | #2
Pushed to master with suggested change, thanks for the review! :-)
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 38b342f770..048e27f8ff 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1927,3 +1927,27 @@  languages, it contains Japanese characters, including Kana glyphs and more
 than 5,300 Kanji glyphs, as well major international phonetic symbols,
 operators and special symbols.")
     (license (license:non-copyleft "file:///LICENSE_E"))))
+
+(define-public font-catamaran
+  (let ((commit "7559b4906f9c9148fb22c6f89508c3053a78a296")
+        (revision "1"))
+    (package
+      (name "font-catamaran")
+      (version (git-version "20170622" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/VanillaandCream/Catamaran-Tamil")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1wpp41l7j2kpgnyavhgxcc5wp852a4wqsnwravn39gp980s84yxw"))))
+      (build-system font-build-system)
+      (home-page "https://github.com/VanillaandCream/Catamaran-Tamil")
+      (synopsis "9 weight Tamil and Latin type")
+      (description "Catamaran is a 9 weight Tamil and Latin type.  Catamaran
+is a stylish type with a polished yet relaxed feel.  Its versatility makes it
+suitable for a wide range of uses.")
+      (license license:silofl1.1))))