diff mbox series

[bug#42229,[PATCH,v3] 2/4] gnu: opendht: Fix compilation of software using this package.

Message ID 20200712160049.6541-2-tona_kosmicznego_smiecia@interia.pl
State Accepted
Headers show
Series [bug#42229,[PATCH,v3] 2/4] gnu: opendht: Fix compilation of software using this package. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jan Wielkiewicz July 12, 2020, 4 p.m. UTC
The 2.1.4 release of opendht contains a bug, which makes it
impossible to terminate a http request, making it unusable.
I patched the version with this commit:
https://github.com/savoirfairelinux/opendht/commit/e2b39dd3a0742853e00f9c3e8c46c911da20bed7

* gnu/packages/patches/opendht-fix-jami.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/networking.scm (opendht)[source]:
Apply the patch.
---
 gnu/local.mk                                |  1 +
 gnu/packages/networking.scm                 |  1 +
 gnu/packages/patches/opendht-fix-jami.patch | 33 +++++++++++++++++++++
 3 files changed, 35 insertions(+)
 create mode 100644 gnu/packages/patches/opendht-fix-jami.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 3046a840c9..12795b754b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1344,6 +1344,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/openbabel-fix-crash-on-nwchem-output.patch	\
   %D%/packages/patches/opencascade-oce-glibc-2.26.patch		\
   %D%/packages/patches/opencv-rgbd-aarch64-test-fix.patch	\
+  %D%/packages/patches/opendht-fix-jami.patch		\
   %D%/packages/patches/openfoam-4.1-cleanup.patch			\
   %D%/packages/patches/openjdk-10-idlj-reproducibility.patch	\
   %D%/packages/patches/openmpi-mtl-priorities.patch		\
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index e6a9e69adf..44f81c94d1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2918,6 +2918,7 @@  and targeted primarily for asynchronous processing of HTTP-requests.")
                     (url "https://github.com/savoirfairelinux/opendht.git")
                     (commit version)))
               (file-name (git-file-name name version))
+              (patches (search-patches "opendht-fix-jami.patch"))
               (sha256
                (base32
                 "1ax26ri1ifb6s8ppd28jmanka9yf8mw3np65q2h4djhhik0phhal"))))
diff --git a/gnu/packages/patches/opendht-fix-jami.patch b/gnu/packages/patches/opendht-fix-jami.patch
new file mode 100644
index 0000000000..9718a84a41
--- /dev/null
+++ b/gnu/packages/patches/opendht-fix-jami.patch
@@ -0,0 +1,33 @@ 
+From e2b39dd3a0742853e00f9c3e8c46c911da20bed7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Adrien=20B=C3=A9raud?= <adrien.beraud@savoirfairelinux.com>
+Date: Tue, 30 Jun 2020 10:42:49 -0400
+Subject: [PATCH 1/4] http/request: make terminate public
+
+---
+ include/opendht/http.h | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/include/opendht/http.h b/include/opendht/http.h
+index cc8d5f9..46b722c 100644
+--- a/include/opendht/http.h
++++ b/include/opendht/http.h
+@@ -294,6 +294,7 @@ public:
+      * User action to cancel the Request and call the completion callbacks.
+      */
+     void cancel();
++    void terminate(const asio::error_code& ec);
+ 
+ private:
+     using OnCompleteCb = std::function<void()>;
+@@ -320,8 +321,6 @@ private:
+ 
+     void connect(std::vector<asio::ip::tcp::endpoint>&& endpoints, HandlerCb cb = {});
+ 
+-    void terminate(const asio::error_code& ec);
+-
+     void post();
+ 
+     void handle_request(const asio::error_code& ec);
+-- 
+2.27.0
+