diff mbox series

[bug#42229,[PATCH,V2] 04/10] gnu: jami: Fetch from git, update to 20200702-guix.

Message ID 20200710183220.19829-4-tona_kosmicznego_smiecia@interia.pl
State Accepted
Headers show
Series [bug#42229,[PATCH,V2] 04/10] gnu: jami: Fetch from git, update to 20200702-guix. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jan Wielkiewicz July 10, 2020, 6:32 p.m. UTC
* gnu/packages/jami.scm:
(jami)[revision, commit]: New variables.
[version]: Use [%jami-version, revision, commit].
[source]: Fetch from git.
[arguments]: Do not change the directory.
---
 gnu/packages/jami.scm | 76 +++++++++++++++++++++++--------------------
 1 file changed, 41 insertions(+), 35 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 1da50d7744..a9ccf67380 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -558,46 +558,52 @@  This package provides a library common to all Jami clients.")
       (license license:gpl3+))))
 
 (define-public jami
-  (package
-    (inherit libring)
-    (name "jami")
-    (build-system cmake-build-system)
-    (inputs
-     `(("libringclient" ,libringclient)
-       ("gtk+" ,gtk+)
-       ("qrencode" ,qrencode)
-       ("libnotify" ,libnotify)
-       ("clutter" ,clutter)
-       ("clutter-gtk" ,clutter-gtk)
-       ("libcanberra" ,libcanberra)
-       ("webkitgtk" ,webkitgtk)
-       ("sqlite" ,sqlite)))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("gettext" ,gettext-minimal)
-       ("glib:bin" ,glib "bin")
-       ("doxygen" ,doxygen)))
-    (propagated-inputs
-     `(("libring" ,libring) ; Contains `dring', the daemon, which is automatically by d-bus.
-       ("adwaita-icon-theme" ,adwaita-icon-theme)
-       ("evolution-data-server" ,evolution-data-server)))
-    (arguments
-     `(#:tests? #f                      ; There is no testsuite.
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'change-directory
-           (lambda _
-             (chdir "client-gnome")
-             #t)))))
-    (synopsis "Distributed, privacy-respecting communication program")
-    (description "Jami (formerly GNU Ring) is a secure and distributed voice,
+  (let ((commit "4703bf11348170da151c62a6a3ae54f83a7d866e")
+        (revision "0"))
+    (package
+      (name "jami")
+      (version (git-version %jami-version revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://review.jami.net/ring-client-gnome")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0fzzgw6738gqvy4m9hamxdzkgbmv72j7zyxzcyaw21zmwacn7jfj"))))
+      (build-system cmake-build-system)
+      (inputs
+       `(("libringclient" ,libringclient)
+         ("gtk+" ,gtk+)
+         ("qtbase" ,qtbase)
+         ("qrencode" ,qrencode)
+         ("libnotify" ,libnotify)
+         ("clutter" ,clutter)
+         ("clutter-gtk" ,clutter-gtk)
+         ("libcanberra" ,libcanberra)
+         ("webkitgtk" ,webkitgtk)
+         ("sqlite" ,sqlite)))
+      (native-inputs
+       `(("pkg-config" ,pkg-config)
+         ("gettext" ,gettext-minimal)
+         ("glib:bin" ,glib "bin")
+         ("doxygen" ,doxygen)))
+      (propagated-inputs
+       `(("libring" ,libring) ; Contains `dring', the daemon, which is automatically by d-bus.
+         ("adwaita-icon-theme" ,adwaita-icon-theme)
+         ("evolution-data-server" ,evolution-data-server)))
+      (arguments
+       `(#:tests? #f)) ; There is no testsuite.
+      (synopsis "Distributed, privacy-respecting communication program")
+      (description "Jami (formerly GNU Ring) is a secure and distributed voice,
 video and chat communication platform that requires no centralized server and
 leaves the power of privacy in the hands of the user.  It supports the SIP and
 IAX protocols, as well as decentralized calling using P2P-DHT.
 
 This package provides the Jami client for the GNOME desktop.")
-    (home-page "https://jami.net")
-    (license license:gpl3+)))
+      (home-page "https://jami.net")
+      (license license:gpl3+))))
 
 (define-public jami-client-gnome
   (deprecated-package "jami-client-gnome" jami))