diff mbox series

[bug#42229,[PATCH,V2] 02/10] gnu: libringclient: Fetch from git, update to 20200702-guix.

Message ID 20200710183220.19829-2-tona_kosmicznego_smiecia@interia.pl
State Accepted
Headers show
Series [bug#42229,[PATCH,V2] 02/10] gnu: libringclient: Fetch from git, update to 20200702-guix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jan Wielkiewicz July 10, 2020, 6:32 p.m. UTC
* gnu/packages/jami.scm
(libringclient):
[revision, commit]: New variables.
Do not inherit from (libring).
[version]: Use (%jami-version, revision, commit).
[source]: Fetch from git.
---
 gnu/packages/jami.scm | 65 ++++++++++++++++++++++++-------------------
 1 file changed, 36 insertions(+), 29 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 06aeafea5d..abb0edc933 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -516,40 +516,47 @@  functionality.")
     (license license:gpl3+)))
 
 (define-public libringclient
-  (package
-    (inherit libring)
-    (name "libringclient")
-    (build-system cmake-build-system)
-    (propagated-inputs
-     `(("libring" ,libring)     ; For 'dring'.
-       ("qtbase" ,qtbase)       ; Qt is included in several installed headers.
-       ("qttools" ,qttools)))
-    (arguments
-     `(#:tests? #f                      ; There is no testsuite.
-       #:configure-flags
-       (list (string-append "-DRING_BUILD_DIR="
-                            (assoc-ref %build-inputs "libring") "/include"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'change-directory
-           (lambda _
-             (chdir "lrc")
-             #t))
-         (add-before 'configure 'fix-dbus-interfaces-path
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "CMakeLists.txt"
-               (("\\$\\{CMAKE_INSTALL_PREFIX\\}(/share/dbus-1/interfaces)" _ dbus-interfaces-path-suffix)
-                (string-append (assoc-ref inputs "libring")
-                               dbus-interfaces-path-suffix))))))))
-    (synopsis "Distributed multimedia communications platform")
-    (description "Jami (formerly GNU Ring) is a secure and distributed voice,
+  (let ((commit "db943766917eba7be3a6f89d41794c2d26363ab7")
+        (revision "0"))
+    (package
+      (name "libringclient")
+      (version (git-version %jami-version revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://review.jami.net/ring-lrc")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1s1wi80drabfjhvxbiyl8k9c2jsafvmx5v84s3wldsmmdg4f6xdf"))))
+      (build-system cmake-build-system)
+      (propagated-inputs
+       `(("libring" ,libring)     ; For 'dring'.
+         ("qtbase" ,qtbase)       ; Qt is included in several installed headers.
+         ("qttools" ,qttools)))
+      (arguments
+       `(#:tests? #f                      ; There is no testsuite.
+         #:configure-flags
+         (list (string-append "-DRING_BUILD_DIR="
+                              (assoc-ref %build-inputs "libring") "/include"))
+         #:phases
+         (modify-phases %standard-phases
+           (add-before 'configure 'fix-dbus-interfaces-path
+             (lambda* (#:key inputs #:allow-other-keys)
+               (substitute* "CMakeLists.txt"
+                 (("\\$\\{CMAKE_INSTALL_PREFIX\\}(/share/dbus-1/interfaces)" _ dbus-interfaces-path-suffix)
+                  (string-append (assoc-ref inputs "libring")
+                                 dbus-interfaces-path-suffix))))))))
+      (synopsis "Distributed multimedia communications platform")
+      (description "Jami (formerly GNU Ring) is a secure and distributed voice,
 video and chat communication platform that requires no centralized server and
 leaves the power of privacy in the hands of the user.  It supports the SIP and
 IAX protocols, as well as decentralized calling using P2P-DHT.
 
 This package provides a library common to all Jami clients.")
-    (home-page "https://jami.net")
-    (license license:gpl3+)))
+      (home-page "https://jami.net")
+      (license license:gpl3+))))
 
 (define-public jami
   (package