diff mbox series

[bug#42177,2/3] gnu: Add template-glib.

Message ID 20200703103713.3510-2-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series Add GNOME Builder | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Prikler July 3, 2020, 10:37 a.m. UTC
* gnu/packages/gnome.scm (template-glib): New variable.
---
 gnu/packages/gnome.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Ludovic Courtès July 10, 2020, 9:21 p.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> skribis:

> * gnu/packages/gnome.scm (template-glib): New variable.

This one was unnecessary: we already have it.  :-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 520129618c..c0517a5421 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10511,3 +10511,32 @@  to generate stacktraces which are then interpreted by the userspace program
 ``sysprof''.")
     (license (list license:gpl2+
                    license:gpl3+))))
+
+(define-public template-glib
+  (package
+    (name "template-glib")
+    (version "3.34.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1z9xkin5fyfh071ma9y045jcw83hgx33dfbjraw6cxk0qdmfysr1"))))
+    (build-system meson-build-system)
+    (inputs
+     `(("bison" ,bison)
+       ("flex" ,flex)
+       ("glib" ,glib)
+       ("gobject-introspection" ,gobject-introspection)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("glib:bin" ,glib "bin")
+       ("vala" ,vala)))
+    (home-page "https://gitlab.gnome.org/GNOME/template-glib")
+    (synopsis "Library for template expansion")
+    (description "Template-GLib is a library to help you generate text based
+on a template and user defined state.  Template-GLib does not use a language
+runtime, so it is safe to use from any GObject-Introspectable language.")
+    (license license:lgpl2.1+)))