diff mbox series

[bug#42132] gnu: gfortran: Remove unusable versions.

Message ID 20200629204819.8685-1-kuba@kadziolka.net
State Accepted
Headers show
Series [bug#42132] gnu: gfortran: Remove unusable versions. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Maja Kądziołka June 29, 2020, 8:48 p.m. UTC
The gfortran packages cannot be used without being wrapped with
gfortran-toolchain. However, as the comment in (gnu packages
commencement) explains, there cannot be more than one gfortran-toolchain
package because of ABI issues. Thus, versions of gfortran other than the
main one are useless.

* gnu/packages/gcc.scm (gfortran-4.8, gfortran-4.9, gfortran-5,
  gfortran-6, gfortran-7, gfortran-8, gfortran-9): Remove variables.
  (gfortran): Define the gfortran package based on the gcc variable.
---
 gnu/packages/gcc.scm | 41 ++---------------------------------------
 1 file changed, 2 insertions(+), 39 deletions(-)

Comments

Ludovic Courtès June 30, 2020, 9:23 a.m. UTC | #1
Hello,

Jakub Kądziołka <kuba@kadziolka.net> skribis:

> The gfortran packages cannot be used without being wrapped with
> gfortran-toolchain. However, as the comment in (gnu packages
> commencement) explains, there cannot be more than one gfortran-toolchain
> package because of ABI issues. Thus, versions of gfortran other than the
> main one are useless.
>
> * gnu/packages/gcc.scm (gfortran-4.8, gfortran-4.9, gfortran-5,
>   gfortran-6, gfortran-7, gfortran-8, gfortran-9): Remove variables.
>   (gfortran): Define the gfortran package based on the gcc variable.

LGTM, thanks!  :-)

Ludo’.
Maja Kądziołka June 30, 2020, 11:01 a.m. UTC | #2
On Tue, Jun 30, 2020 at 11:23:00AM +0200, Ludovic Courtès wrote:
> Hello,
> 
> Jakub Kądziołka <kuba@kadziolka.net> skribis:
> 
> > The gfortran packages cannot be used without being wrapped with
> > gfortran-toolchain. However, as the comment in (gnu packages
> > commencement) explains, there cannot be more than one gfortran-toolchain
> > package because of ABI issues. Thus, versions of gfortran other than the
> > main one are useless.
> >
> > * gnu/packages/gcc.scm (gfortran-4.8, gfortran-4.9, gfortran-5,
> >   gfortran-6, gfortran-7, gfortran-8, gfortran-9): Remove variables.
> >   (gfortran): Define the gfortran package based on the gcc variable.
> 
> LGTM, thanks!  :-)
> 
> Ludo’.

Thanks, pushed as 0681f05486d901c92637c098bb7afddef35068b0.

Regards,
Jakub Kądziołka
diff mbox series

Patch

diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 0c5be69fbf..31d88f2e0b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -687,48 +687,11 @@  as the 'native-search-paths' field."
          (variable "LIBRARY_PATH")
          (files '("lib" "lib64")))))
 
-(define-public gfortran-4.8
-  (hidden-package
-   (custom-gcc gcc-4.8 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-4.9
-  (hidden-package
-   (custom-gcc gcc-4.9 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-5
-  (hidden-package
-   (custom-gcc gcc-5 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-6
-  (hidden-package
-   (custom-gcc gcc-6 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-7
-  (hidden-package
-   (custom-gcc gcc-7 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-8
-  (hidden-package
-   (custom-gcc gcc-8 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-9
+(define-public gfortran
   (hidden-package
-   (custom-gcc gcc-9 "gfortran" '("fortran")
+   (custom-gcc gcc "gfortran" '("fortran")
                %generic-search-paths)))
 
-(define-public gfortran
-  ;; Note: Update this when GCC changes!  We cannot use
-  ;; (custom-gcc gcc "fortran" …) because that would lead to a package object
-  ;; that is not 'eq?' with GFORTRAN-5, and thus 'fold-packages' would
-  ;; report two gfortran@5 that are in fact identical.
-  gfortran-7)
-
 (define-public libgccjit
   (package
     (inherit gcc-9)