diff mbox series

[bug#42130] gnu: Add lld.

Message ID 20200629203648.3429-1-kuba@kadziolka.net
State Accepted
Headers show
Series [bug#42130] gnu: Add lld. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Maja Kądziołka June 29, 2020, 8:36 p.m. UTC
* gnu/packages/llvm.scm (lld): New variable.
---
 gnu/packages/llvm.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Ludovic Courtès July 2, 2020, 9:39 p.m. UTC | #1
Hi,

Jakub Kądziołka <kuba@kadziolka.net> skribis:

> * gnu/packages/llvm.scm (lld): New variable.

LGTM, thanks!

Ludo’.
Maja Kądziołka July 2, 2020, 11:38 p.m. UTC | #2
On Thu, Jul 02, 2020 at 11:39:15PM +0200, Ludovic Courtès wrote:
> Hi,
> 
> Jakub Kądziołka <kuba@kadziolka.net> skribis:
> 
> > * gnu/packages/llvm.scm (lld): New variable.
> 
> LGTM, thanks!

Thanks, pushed as 5ce123bd9a1597bdbb8c1a83fb73ae82a0b86f60.

Regards,
Jakub Kądziołka
diff mbox series

Patch

diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 11e4cfbe4c..62cfb17727 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -15,6 +15,7 @@ 
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -532,6 +533,30 @@  output), and Binutils.")
 (define-public clang clang-9)
 (define-public clang-toolchain clang-toolchain-9)
 
+(define-public lld
+  (package
+    (name "lld")
+    (version (package-version llvm-10))
+    (source (origin
+              (method url-fetch)
+              (uri (llvm-download-uri "lld" version))
+              (sha256
+               (base32
+                "026pwcbczcg0j5c9h7hxxrn3ki81ia9m9sfn0sy0bvzffv2xg85r"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("llvm" ,llvm-10)))
+    (arguments
+     `(#:build-type "Release"
+       ;; TODO: Tests require the lit tool, which isn't installed by the LLVM
+       ;; package.
+       #:tests? #f))
+    (home-page "https://lld.llvm.org/")
+    (synopsis "Linker from the LLVM project")
+    (description "LLD is a high-performance linker, built as a set of reusable
+components which highly leverage existing libraries in the larger LLVM Project.")
+    (license license:asl2.0))) ; With LLVM exception
+
 (define-public llvm-8
   (package
     (inherit llvm)