diff mbox series

[bug#42124] gnu: python-gevent: Propagate dependencies.

Message ID 20200629142707.6446-1-kraai@ftbfs.org
State Accepted
Headers show
Series [bug#42124] gnu: python-gevent: Propagate dependencies. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Matthew James Kraai June 29, 2020, 2:27 p.m. UTC
* gnu/packages/python-xyz.scm (python-gevent)[native-inputs]: Move
python-zope-event and python-zone-interface to ...
[propagated-inputs]: ... here.
---
 gnu/packages/python-xyz.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès July 2, 2020, 9:38 p.m. UTC | #1
Hi,

Matthew Kraai <kraai@ftbfs.org> skribis:

> * gnu/packages/python-xyz.scm (python-gevent)[native-inputs]: Move
> python-zope-event and python-zone-interface to ...
> [propagated-inputs]: ... here.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f7ef5da62f..d9310286f2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11604,15 +11604,15 @@  graphviz.")
                               "known_failures.py" "--ignore" "skipped_tests.txt"))))))
     (propagated-inputs
      `(("python-greenlet" ,python-greenlet)
-       ("python-objgraph" ,python-objgraph)))
+       ("python-objgraph" ,python-objgraph)
+       ("python-zope.event" ,python-zope-event)
+       ("python-zope.interface" ,python-zope-interface)))
     (native-inputs
      `(("python-six" ,python-six)
 
        ;; For tests.
        ("python-dnspython" ,python-dnspython)
-       ("python-psutil" ,python-psutil)
-       ("python-zope.event" ,python-zope-event)
-       ("python-zope.interface" ,python-zope-interface)))
+       ("python-psutil" ,python-psutil)))
     (inputs
      `(("c-ares" ,c-ares)
        ("libev" ,libev)))