diff mbox series

[bug#42119,3/5] gnu: Add r-perm.

Message ID 20200629080340.13200-3-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42119,1/5] gnu: Add r-icens. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 29, 2020, 8:03 a.m. UTC
* gnu/packages/cran.scm (r-perm): New variable.
---
 gnu/packages/cran.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8be110a9bd..fe1a8e0b46 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22354,3 +22354,24 @@  methods can also be used for univariate censored data (see data set
 set @code{menopause}).  We also provide functions to visualize the
 observed data and the MLE.")
     (license license:gpl2+)))
+
+(define-public r-perm
+  (package
+    (name "r-perm")
+    (version "1.0-0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "perm" version))
+        (sha256
+          (base32
+            "0075awl66ynv10vypg63fcxk33qzvxddrp8mi4w08ysvimcyxijk"))))
+    (properties `((upstream-name . "perm")))
+    (build-system r-build-system)
+    (home-page
+      "https://cran.r-project.org/web/packages/perm/")
+    (synopsis
+      "Exact or Asymptotic permutation tests")
+    (description
+      "Perform Exact or Asymptotic permutation tests")
+    (license (list license:gpl2+ license:gpl3+))))