diff mbox series

[bug#42106,3/4] gnu: Add r-config.

Message ID 20200628085745.15796-3-peterloleungyau@gmail.com
State New
Headers show
Series [bug#42106,1/4] gnu: Add r-r2d3. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 28, 2020, 8:57 a.m. UTC
* gnu/packages/cran.scm (r-config): New variable.
---
 gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 93a487deb3..8d72cfdd78 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22378,3 +22378,28 @@  distributing @code{D3} based @code{htmlwidgets} in R packages.")
       "Helper functions with a consistent interface to coerce and
 verify the types and shapes of values for input checking.")
     (license license:asl2.0)))
+
+(define-public r-config
+  (package
+    (name "r-config")
+    (version "0.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "config" version))
+        (sha256
+          (base32
+            "0l67nfpm42ssnk0bl4jmq6bibz8hawgfgh2s14s5c8mnimv6mpjs"))))
+    (properties `((upstream-name . "config")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-yaml" ,r-yaml)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/rstudio/config")
+    (synopsis
+      "Manage Environment Specific Configuration Values")
+    (description
+      "Manage configuration values across multiple environments (e.g.
+development, test, production).  Read values using a function that
+determines the current environment and returns the appropriate
+value.")
+    (license license:gpl3)))