diff mbox series

[bug#42105] gnu: Add r-randomforestsrc.

Message ID 20200628081029.11086-1-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42105] gnu: Add r-randomforestsrc. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 28, 2020, 8:10 a.m. UTC
* gnu/packages/cran.scm (r-randomforestsrc): New variable.
---
 gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Ricardo Wurmus April 13, 2021, 12:44 p.m. UTC | #1
My apologies for overlooking this patch!  I just applied it.

I tried upgrading the package, but the newer version indirectly 
depends on visnetwork, which bundles a lot of minified JavaScript, 
so I’ll leave that for later.  Thank you for the patch!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab5e57c0e2..1a5ff5ef8e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22325,3 +22325,31 @@  across a wide array of bioinformatic R packages.")
 and clustering large sequence datasets using fast alignment-free k-mer
 counting and recursive k-means partitioning.")
     (license license:gpl3)))
+
+(define-public r-randomforestsrc
+  (package
+    (name "r-randomforestsrc")
+    (version "2.9.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "randomForestSRC" version))
+        (sha256
+          (base32
+            "05ifvj49jv0n5p6k46milpgj9r10sc5aw23fypyyibdgwpwvwixw"))))
+    (properties
+      `((upstream-name . "randomForestSRC")))
+    (build-system r-build-system)
+    (home-page
+      "https://cran.r-project.org/web/packages/randomForestSRC/")
+    (synopsis
+      "Fast Unified Random Forests for Survival, Regression, and Classification")
+    (description
+      "Fast OpenMP parallel computing of Breiman's random forests for
+survival, competing risks, regression and classification based on
+Ishwaran and Kogalur's popular random survival forests (RSF) package.
+Handles missing data and now includes multivariate, unsupervised
+forests, quantile regression and solutions for class imbalanced data.
+New fast interface using subsampling and confidence regions for
+variable importance.")
+    (license license:gpl3+)))