diff mbox series

[bug#42103,1/2] gnu: Add r-muhaz.

Message ID 20200628074414.6986-1-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42103,1/2] gnu: Add r-muhaz. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 28, 2020, 7:44 a.m. UTC
* gnu/packages/cran.scm (r-muhaz): New variable.
---
 gnu/packages/cran.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab5e57c0e2..b6cc9b48c3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22325,3 +22325,26 @@  across a wide array of bioinformatic R packages.")
 and clustering large sequence datasets using fast alignment-free k-mer
 counting and recursive k-means partitioning.")
     (license license:gpl3)))
+
+(define-public r-muhaz
+  (package
+    (name "r-muhaz")
+    (version "1.2.6.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "muhaz" version))
+        (sha256
+          (base32
+            "08qh43zx6h3yby44q2vxphfvmfdmqxpgyp0734yn341sy9n8pkkk"))))
+    (properties `((upstream-name . "muhaz")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-survival" ,r-survival)))
+    (native-inputs `(("gfortran" ,gfortran)))
+    (home-page
+      "https://cran.r-project.org/web/packages/muhaz")
+    (synopsis
+      "Hazard Function Estimation in Survival Analysis")
+    (description
+      "Produces a smooth estimate of the hazard function for censored data.")
+    (license (list license:gpl2+ license:gpl3+))))