diff mbox series

[bug#42102] gnu: Add r-fastshap.

Message ID 20200628071619.4030-1-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42102] gnu: Add r-fastshap. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 28, 2020, 7:16 a.m. UTC
* gnu/packages/cran.scm (r-fastshap): New variable.
---
 gnu/packages/cran.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Ricardo Wurmus Aug. 4, 2020, 2:49 p.m. UTC | #1
Hi Peter,

thank you for this patch.  I made minor changes to indentation and
description and pushed it to the master branch with commit 285bd00cd4.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab5e57c0e2..03e6bf6189 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22325,3 +22325,36 @@  across a wide array of bioinformatic R packages.")
 and clustering large sequence datasets using fast alignment-free k-mer
 counting and recursive k-means partitioning.")
     (license license:gpl3)))
+
+(define-public r-fastshap
+  (package
+    (name "r-fastshap")
+    (version "0.0.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "fastshap" version))
+        (sha256
+          (base32
+            "08f25ib5mry6h8lvj0g3clc9kfl5g2wdd8x8bw455wwmbcm6x5vg"))))
+    (properties `((upstream-name . "fastshap")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-abind" ,r-abind)
+        ("r-ggplot2" ,r-ggplot2)
+        ("r-gridextra" ,r-gridextra)
+        ("r-matrixstats" ,r-matrixstats)
+        ("r-plyr" ,r-plyr)
+        ("r-rcpp" ,r-rcpp)
+        ("r-rcpparmadillo" ,r-rcpparmadillo)
+        ("r-tibble" ,r-tibble)))
+    (home-page
+      "https://github.com/bgreenwell/fastshap")
+    (synopsis "Fast Approximate Shapley Values")
+    (description
+      "Computes fast (relative to other implementations) approximate
+Shapley values for any supervised learning model.  Shapley values help
+to explain the predictions from any black box model using ideas from
+game theory; see Strumbel and Kononenko (2014)
+<doi:10.1007/s10115-013-0679-x> for details.")
+    (license license:gpl2+)))