diff mbox series

[bug#42086,5/6] gnu: Add python-pytest-env.

Message ID 20200627154645.64264-5-monego@posteo.net
State Accepted
Headers show
Series [bug#42082,1/6] gnu: Add python-covdefaults. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego June 27, 2020, 3:46 p.m. UTC
* gnu/packages/check.scm (python-pytest-env): New variable.
---
 gnu/packages/check.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Marius Bakke July 20, 2020, 9:27 p.m. UTC | #1
Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/check.scm (python-pytest-env): New variable.

python-check.scm is better here too, even though pytest lives
elsewhere.

[...]

> +(define-public python-pytest-env
> +  (package
> +    (name "python-pytest-env")
> +    (version "0.6.2")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "pytest-env" version))
> +       (sha256
> +        (base32 "1hl0ln0cicdid4qjk7mv90lw9xkb0v71dlj7q7rn89vzxxm9b53y"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +     `(("python-pytest" ,python-pytest)))

As mentioned in another patch, it's good not to propagate the package
that this one "plugs in to", in order to allow using it with other
versions.

> +    (home-page "https://github.com/MobileDynasty/pytest-env")
> +    (synopsis "Pytest plugin that allows you to add environment variables")
> +    (description
> +     "This is a py.test plugin that enables you to set environment variables
> +in the pytest.ini file.")

@command{py.test} and @file{pytest.ini}.
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c2435a78af..f03d1f42fe 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -933,6 +933,26 @@  and many external plugins.")
         ("python-py" ,python2-py)
         ("python-wcwidth" ,python2-wcwidth))))))
 
+(define-public python-pytest-env
+  (package
+    (name "python-pytest-env")
+    (version "0.6.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-env" version))
+       (sha256
+        (base32 "1hl0ln0cicdid4qjk7mv90lw9xkb0v71dlj7q7rn89vzxxm9b53y"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/MobileDynasty/pytest-env")
+    (synopsis "Pytest plugin that allows you to add environment variables")
+    (description
+     "This is a py.test plugin that enables you to set environment variables
+in the pytest.ini file.")
+    (license license:expat)))
+
 (define-public python-pytest-cov
   (package
     (name "python-pytest-cov")