diff mbox series

[bug#42083,2/6] gnu: Add python-cfgv.

Message ID 20200627154645.64264-2-monego@posteo.net
State Accepted
Headers show
Series [bug#42082,1/6] gnu: Add python-covdefaults. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego June 27, 2020, 3:46 p.m. UTC
* gnu/packages/python-xyz.scm (python-cfgv): New variable.
---
 gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Marius Bakke July 20, 2020, 9:17 p.m. UTC | #1
Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/python-xyz.scm (python-cfgv): New variable.

[...]

> +    (synopsis "Validate configuration and produce human readable error messages")

Maybe just 'Configuration validation library'.

> +    (description
> +     "This library helps to validate configuration and produce human readable
> +error messages.")

*configuration files (I think?)

Otherwise LGTM, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 300277f045..ac839a4e16 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17210,6 +17210,39 @@  Let's Encrypt.")
 (define-public python2-dns-lexicon
   (package-with-python2 python-dns-lexicon))
 
+(define-public python-cfgv
+  (package
+    (name "python-cfgv")
+    (version "3.1.0")
+    (source
+     (origin
+       ;; There are no tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/asottile/cfgv")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1vvkkqw92sak4b28bpscpppq483amy52ch2yqy1i2m23q7xjkabx"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "pytest" "-vv")
+             #t)))))
+    (native-inputs
+     `(("python-covdefaults" ,python-covdefaults)
+       ("python-coverage" ,python-coverage)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/asottile/cfgv")
+    (synopsis "Validate configuration and produce human readable error messages")
+    (description
+     "This library helps to validate configuration and produce human readable
+error messages.")
+    (license license:expat)))
+
 (define-public python-commandlines
   (package
     (name "python-commandlines")